Title page

SkyAssistant

Variomètre et enregistreur pour Planeurs R/C

SkyAssistant

Manuel utilisateur et documentation technique

Version française

Documentation version 1.31

Applicable aux versions :
matériel 2.31
logiciel 2.31

http://www.pitlab.eu/wario_en.html
(c) PitLab 2003-2009, traduction en français par P. Berthouze


Interface utilisateur

Le logiciel de configuration permet software provide full functionality operation and visualisation of recorded flight data. Deux modes de communication avec le SkyAssistant sont disponibles :

  • en utilisant le logiciel de configuration : les informations émises ou reçues par l'utilisateur sont envoyées par l'interface suivante :

    Menu principal : envoi de commandes utilisateur.
    Barre d'outils : envoi de commandes utilisateur et contrôle des fenêtres d'affichage des graphes.
    Panneau de mesures : affichage des informations concernant les données en cours de mesure.
    Barre d'état : affichage de l'état du SkyAssistant.

  • en utilisant la configuration off-line qui consiste en une communication interactive entre l'utilisateur et le SkyAssistant au moyen de messages vocaux et de commandes PPM. La configuration off-line ne concerne que les paramètres principaux.

    Le logiciel de configuratin ne nécessaite pas d'installation. Il suffit de le copier sur le disque dur du PC, dans un répertoire quelconque, pour pouvoir le lancer.


Panneau d'affichage des mesures

Ce panneau est utilisé pour l'affichage des mesures en cours, lorsque l'utilisateur a cliqué sur le bouton "Lire les données" Read measurement situé dans la barre d'outils.

En fonction du type d'unités choisi, l'affichage des valeurs se fera en système métrique :

Measurement panel - metric units

ou en système impérial :

Measurement panel - imperial units

Le panneau peut être ouvert ou fermé en utilisant le menu Afficher, puis en cliquant sur Panneau de mesures. Une fois le panneau fermé, le bouton "Lire les données" devient inactif.


Affichage des documents

Vario.exe est une application multi documents, ce qui permet d'ouvrir en une fois plusieurs documents. Chaque document dispose de sa propre fenêtre d'affichage. Le passage d'une fenêtre à l'autre se fait en utilisant les commandes du menu "Fenêtre".

La fenêtre ci-dessous permet l'affichage des vols enregistrés. Elle est divisée en trois panneaux :

  • Le panneau Session (panneau gauche) affiche la liste des sessions disponibles dans le fichier d'enregistrement. Une session est une période de fonctionnement du SkyAssistant (depuis la mise sous tension jusqu'à la mise hors tension). Pour supprimer une session, il suffit de la sélectionner puis, en utilisant le clic droit de la souris, de sélectionner "remove session" dans le menu contextuel. Après confirmation, la session est effacée.

  • Le panneau Graphe (panneau supérieur droit) affiche l'interprétation graphique des paramètres enregistrés. Ces courbes peuvent être agrandies ou réduites selon l'axe temporel (symbole loupe de la barre d'outils)

  • Le panneau Données et statistiques est placé sous le panneau Graphe. Il contient deux lignes de données. La première ligne présente les données désignées par le curseur de la souris. La seconde ligne contient des informations sur les échelles de données selectionnées : échelle de temps, échelle d'altitude (mini et maxi pour l'échelle de temps considérée), la variation d'altitude correspondante, les vitesses verticales moyennes.

    Document window

    Sur le graphe, l'altitude est tracée en vert. L'échelle d'altitude est disponible sur l'axe vertical gauche. Le graphe en altitude dipose d'un quadrillage gris foncé permettant de mettre plus facilement en évidence les niveaux d'altitude atteints. L'altitude nulle est toujours repérée par une ligne continue.

    • Les courbes de température sont placées en haut du graphe :

  • La température externe est tracée en bleu foncé,
  • La température interne est tracée en violet.

    • L'échelle de température est placée sur la partie haute de l'axe vertical droit.

    Les courbes associées au taux de montée sont placées juste en dessous des courbes de température :

  • Le taux de montée réel enregistré par le circuit analogique du variomètre est tracé en rouge vif (montée) et en bleu vif (descente),
  • Le taux de montée théorique recalculé à partir des variations d'altitude est tracé en rouge pastel (montée) et bleu pastel (descente).

    L'échelle de taux de montée est placée sur l'axe vertical droit.

    Les courbes de Tension tracent les valeurs minimum et maximum de la tension au moyen de lignes jaune vif complété d'un remplissage en jaune pastel. Plus le bruit sur la tension est élevé, plus le remplissage est dense. L'échelle de tension est placée sur l'axe vertical droit.

    La courbe associée au signal PPM est disponible en bas de la fenêtre d'affichage :

  • La valeur du signal (en pourcentage) est tracée en blanc,
  • Le temps séparant les impulsions en [ms] est tracé en gris.

    • Le profil de température est représenté par un nuage de points bleu foncé avec une courbe de tendance (ligne continue épaisse) et la courbe de référence (ligne continue fine -0,7°C/100m). L'équation de la courbe de tendance est donnée en bas du graphe. Elle permet de mettre en évidence le taux de chute de la température en fonction de la montée en altitude. Si le taux de chute est plus fort que -0,7°C/100m, cela signifie que des ascendances thermiques peuvent être attendues. Le profil thermique est la courbe de température en fonction de l'altitude : l'altitude est disponible sur l'axe vertical et la température sur l'axe horizontal. L'échelle de température est figée : la valeur 0 sur l'axe horizontal représente la température mesurée la plus faible.

    Les deux lignes jaunes pointillées verticales sont des curseurs utilisées pour sélectionner une partie du graphe permettant :

  • de mesurer les écarts affichés sur la deuxième ligne du panneau Données et statistiques,
  • de créer des images en cliquant sur le bouton "view" de la barre d'outils.

    Pour sélectionner les premier et dernier point, il suffit de commencer la sélection hors du graphe.


Barre d'outils

La barre d'outils regroupe les boutons utilisés le plus fréquemment. Si l'on place le curseur de la souris sur le bouton, on obtient une bulle donnant la description de la fonction lancée par ce bouton. La description de chacun des boutons est donnée ci-dessous :

Open Ouvrir - permet l'ouverture des documents VGD ou LOG disponibles sur le disque du PC.
Save Sauver - sauve le document en cours sur le disque du PC.
Screenshot Enregistrer une copie d'écran - sauve l'impression écran dans un fichier.
Print Imprimer - imprime le document en cours
About A propos - ouvre une fenêtre contenant des informations sur la version du programme : version logicielle, numéro de série du SkyAssistant et le numéro d'identification du matériel.
Help Aide contextuelle - permet de cliquer sur un élément pour obtenir l'aide associée à cet élément.
Height Afficher l'altitude - permet d'afficher ou de supprimer le graphe d'altitude.
Voltage Afficher la tension - permet d'afficher ou de supprimer le graphe de tension.
Real lift Afficher le taux de montée réel - permet d'afficher ou de supprimer le graphe de vitesse verticale mesurée par le SkyAssistant.
Theoretical lift Afficher le taux de montée théorique - permet d'afficher ou de supprimer le graphe de vitesse verticale calculée par le SkyAssistant à partir des informations d'altitude.
Internal temperature Afficher la température interne - permet d'afficher ou de supprimer le graphe de température interne.
External temperature Afficher la température externe - permet d'afficher ou de supprimer le graphe de température externe.
Value of PPM signal Afficher la valeur PPM - permet d'afficher ou de supprimer le graphe de largeur des impulsions du signal PPM (en pourcentage).
Time between PPM pulses Afficher la longueur entre impulsions PPM - permet d'afficher ou de supprimer le graphe d'intervalle de temps entre impulsions du signal PPM.
Temperature profile Afficher le profil de température - permet d'afficher ou de supprimer le graphe de profil de température atmosphérique.
Fit to window Ajuster le graphique à la fenêtre - adapte le graphe à la largeur de la fenêtre d'affichage. Si aucun zoom n'est utilisé, le graphe entier (quelque soit sa longueur) sera affiché dans la fenêtre.
Fit to data Centrer les données dans la fenêtre - adapte l'affichage des données à la fenêtre d'affichage. Si aucun zoom n'est utilisé, un pixel représente une mesure.
Zoom In Agrandir - agrandit le graphe selon l'axe des temps.
Zoom Out Diminuer - reduit le graphe selon l'axe des temps.
Crop Rogner - réduit l'affichage à l'intervalle sélectionné (l'intervalle sélectionné reste présent à l'écran, le reste est enlevé de l'affichage).
Create view Créer vue - crée une nouvelle visualisation à partir des données délimitées par les curseurs positionnés par l'utilisateur. La nouvelle vue est accessible à partir du panneau des sessions.
Read measurement Lire les données - lit le résultat des mesures en cours. Ce bouton est accessible uniquement si le SkyAssistant est connecté et le panneau de mesures visible.


Barre d'état

La barre d'état affiche l'état courant du programme. La partie gauche de la barre d'état est utilisée pour l'affichage des commandes en cours. La partie droite permet l'affichage d'informations (champs pré-définis - voir ci-dessous).

Status bar

Le premier affichage présente le numéro de série du port USB utilisé (PLRFMUPU) et l'état de la connection (Connected). Le second affichage présente l'état d'avancement (Stopped). Le troisième affichage présente la bande radio retenue (LPD) et le numéro de canal (6). Tout à droite de la barre d'état, un "widget" permet de redimensionner la barre d'état.


Menu principal

Le menu principal contient l'ensemble des fonctions permettant le contrôle du SkyAssistant et du logiciel. La liste des commandes disponibles dépend du contenu de la fenêtre d'affichage et du mode d'opération : Basic ou Avancé.

Les commandes sont regroupées de la manière suivante :
Fichier
Afficher
Configuration
Messages vocaux
Test
Window
Aide


Menu de gestion des fichiers

There are following commands in the File menu:

Ouvrir... - permet d'ouvrir les documents au format .VGD ou les fichiers d'enregistrement enregistrés sur le disque dur et d'afficher leur contenu dans la fenêtre d'affichage des documents.

Enregistrer & Enregistrer sous... - permet de sauver le document actif sur le disque dur, au format .VGD.

Enregistrer une copie d'écran... - permet de sauver les impressions écran des graphiques sur le disque dur, au format .GIF.

Conversion Log->Vgd... - permet de convertir les fichiers binaires d'enregistrement en un fichier texte au format .VGD.

Imprimer - permet d'imprimer le document actif. Commande pas encore programmée, peut fonctionner de manière incorrecte.

Aperçu - permet d'ouvrir la fenêtre de prévisualisation de document. Commande pas encore programmée, peut fonctionner de manière incorrecte.

Paramètres d'impression - permet d'ouvrir la fenêtre de configuration de l'imprimante. Commande pas encore programmée, peut fonctionner de manière incorrecte.

Fichiers récents - permet d'accéder rapidement aux 10 derniers fichiers ouverts.

Réinitialiser le SkyAssistant - permet de réinitialiser le logiciel du SkyAssistant.

Fermer - permet de fermer le document actif.

Quitter - permet de fermer l'application. Elle est accessible dans la fenêtre principale, par la combinaison de touches standard Alt + F4 et par l'icône "X" dans le coin supérieur droit de la fenêtre.


Affichage

Barre d'outils - fait apparaître ou disparaître la barre d'outils.

Barre d'état - fait apparaître ou disparaître la barre d'état.

Lecture des mesures - permet la lecture d'un ensemble de résultats de mesures. Ce menu est également disponible dans le menu principal.

Panneau d'affichage des mesures - ouvre le panneau de résultats des données courantes.


Menu de configuration

Le menu de configuration donne accès aux options suivantes :

Mise à jour de l'horloge - permet de régler l'heure du SkyAssistant de manière à la faire correspondre avec l'heure de l'ordinateur.

Mise à jour du logiciel - ouvre la fenêtre de mise à jour automatique du microcontrôleur.

Sélection langue et unités... - permet de choisir la langue et le système d'unités.

Importer la configuration du variomètre... - permet de lire la configuration du SkyAssistant (valeur des variables) et de la sauver dans un fichier. Cela permet ensuite de restaurer cette configuration en cas de besoin.

Exporter la configuration vers le variomètre... - permet d'envoyer le contenu du fichier de configuration vers le SkyAssistant.

Importer la définition des canaux de l'émetteur... - permet de lire la configuration des micro-interrupteurs DIP (c'est à dire les canaux associés à chaque position des micro-interrupteurs).

Exporter la définition des canaux vers l'émetteur... - permet d'envoyer la définition des canaux de l'émetteur vers le SkyAssistant (c'est à dire l'assignation des canaux pour chaque position des micro-interrupteurs).

Importer la définition des préréglages DIP.... - permet de lire la définition des valeurs des micro-interrupteurs DIP à partir du SkyAssistant.

Exporter la définition des préréglages DIP... - permet d'envoyer la définition des valeurs des micro-interrupteurs DIP vers le SkyAssistant (ces valeurs permettent au programme de lire la position de chacun des micro-interrupteurs DIP).

Restaurer les régalages par défaut - permet de remettre toutes les variables dans leur configuration usine. Utiliser cette fonction quand suite aux changements effectués, on perd le contrôle sur le SkyAssistant ou que le SkyAssistant a cessé de fonctionner pour une raison inconnue et que l'on n'a pas de configuration fonctionnelle sauvegardée.

Edition des variables de la mémoire EEPROM... - permet de lire et de modifier les variables de configuration. Attention : cette méthode n'est pas recommandée pour les utilisateurs peu expérimentés.

Mode Avancé ou Mode Basic - permet de basculer entre deux modes d'opération du programme. En mode Basic, seules les commandes les plus importantes sont disponibles dans les menus.

Variomètre... - ouvre la fenêtre de configuration du variomètre.

Emetteur radio... - ouvre la fenêtre de configuration de l'émetteur radio.

Enregistreur... - ouvre la fenêtre de configuration de l'enregistreur.

Réglage des commandes vocales... - ouvre la fenêtre de configuration des messages vocaux.

Evènements PPM... - ouvre la fenêtre de configuration des évènements PPM.

Alertes... - ouvre la fenêtre de configuration des seuils d'alarme.

Traitement des enregistrements... - ouvre la fenêtre de traitement des données.

Profil de température... - ouvre la fenêtre de configuration du profil de température atmosphérique.

Signalisation de déviation d'altitude... - ouvre la fenêtre de configuration de la signalisation de variation d'altitude.


Changement de la langue et du type d'unités

Une boite de dialogue permet de choisir la langue. Les définitions des différentes langues disponibles sont contenues dans des fichiers texte dénommés vario_xxx.lng , où xxx est le code à 3 lettres du pays.

Program language an units type change

La langue sélectionnée apparaît dans la fenêtre Choisir la langue.

Actuellement, les langues suivantes sont disponibles :

  • tchèque,
  • anglais,
  • suomi,
  • français,
  • allemand,
  • grec,
  • hongrois,
  • hollandais,
  • polonais,
  • roumain.

    Le bouton Changer le chemin d'accès permet de changer le chemin d'accès vers le fichier de langue. Le chemin courant est affiché dans la partie inférieure de la fenêtre.

    Le panneau Unités permet de choisir le système d'unités pour les mesures.

    Grandeur mesurée | Système métrique | Système impérial
    Altitude | mètre [m] | pied [ft]
    Taux de montée | mètre par seconde [m/s] | pied par minute [ft/min]
    Température | degré Celsius [°C] | degré Fahrenheit [°F]
    Tension | volt [V] | volt [V]
    Pression | hectoPascal [hPa] | pouce de mercure [inHg]

    Les unités peuvent être identiques à celles utilisées dans le microcontrôleur (automatique) ou forcées à métrique ou impérial.


Edition des variables EEPROM

Avertissement : l'édition des variables est à réserver aux utilisateurs expérimentés. Ces variables peuvent être modifiées de manière plus sécurisée par les fenêtres de configuration du SkyAssistant.

Cette fenêtre de dialogue permet de voir et de modifier directement les variables contenues dans la mémoire EEPROM.

variables in hex format

Par défaut, les valeurs sont affichées en format hexadécimal, mais elles peuvent être affichées en format décimal (et inversement) en utilisant le bouton DEC->HEX.

Pour changer la valeur d'une variable, il est nécessaire de l'éditer. Après une période d'une seconde après le dernier changement effectué, la nouvelle valeur sera auvegardée automatiquement. Pour abandonner tous les changements, cliquer sur le bouton Annuler.

La signification des variables est définie ci-dessous :

EA_SPEECH_CONF - configuration du générateur vocal et du délai entre chaque message vocal.

EA_LOGGER_CONF - configuration de l'enregistreur

EA_SOUND_BREAK - coefficients utilisés dans l'équation gérant la méthode d'interruption du signal du taux de montée.

EA_CLIMB_FACTR - sensibilité du taux de montée : c'est la valeur utilisée pour diviser le signal afin d'obtenir une variation élémentaire du taux de montée de 0,05[m/s]. Plus la valeur est forte, plus la sensibilité est réduite. Une variation du taux de montée égale à cette variation élémentaire sera signalée par une variation d'un pas de la fréquence du signal (sur une échelle de 174 pas). Par défaut, la valeur retenue est celle permettant d'obtenir la sensibilité maximale égale à 0,05m/s.

EA_CLIMB_AVRG - index des constantes de temps du filtre passe-bas du signal du variomètre. C'est la valeur de la puissance à appliquer au chiffre 2 pour obtenir la constante de temps du filtre. Plus la constante de temps est grande, plus la période de coupure est grande et plus le signal du variomètre varie lentement. La valeur peut être fixée dans un intervalle de 0 à 7, ce qui donne une taille de filtre de 2^0 = 1 (le filtre est "ouvert") à 2^7 = 128. Dans ce dernier cas, une mesure étant réalisée toutes les 40ms, la base de temps du filtre égale à 128 x 40ms = 5,12s.

EA_OFST_TEMP - valeur de compensation des deux capteurs de température. Cette valeur est ajoutée au résultat des deux capteurs pour obtenir la même valeur de température mesurée dans le même environnement.

EA_VSIG_DISC - discontinuité du signal sonore pour des taux de montée proches de zéro. La variable contient des informations sur la différence de signal entre une montée minimale et une descente minimale.

EA_PPM_MAX_ERR - nombre maximal d'erreurs PPM en une seconde. Un message d'alerte est émis si ce nombre est atteint.

EA_PPM_RANGE - contient la valeur de la variation de signal PPM qui sera interprétée comme une commande manuelle d'émission d'un message vocal pour les paramètres altitude, tension et température.

EA_VAL_CHANGE - contient les valeurs des variations des paramètres mesurés (altitude, tension et température) permettant de déclencher l'émission d'un message vocal énonçant les informations sur ces variations.

EA_XOSC - valeur du quartz du résonnateur de l'émetteur (en Hz).

EA_ALARM_TEMP - valeur de la température déclenchant l'alarme de température haute.

EA_ALARM_VOLT - valeur de la tension déclenchant l'alarme de tension basse.

EA_INIT_TIME - temps d'initialisation du SkyAssistant après sa mise sous tension (en secondes). Durant cette période, le signal du variomètre est non actif.

EA_ALARM_ALTI - valeur de l'altitude déclenchant l'alarme d'altitude haute.

EA_PPM_LEVEL - bits définissant l'action associée à un niveau de signal PPM de +100% et -100%.

EA_VARIO_RCk - valeurs physiques du module variomètre : R, C et amplification (k). Ces valeurs sont utilisées pour le calcul du modèle mathématique du taux de montée.

EA_ALARM_PPM - définition de l'alerte sur erreurs du signal PPM.

EA_DN_IS_ZONE & EA_UP_IS_ZONE - limites basse et haute de la zone de silence associée à des taux de montée proches de zéro pour lesquels le variomètre ne génère auxun signal sonore. L'unité associée à ces limites est la même que celle utilisée pour la sensibilité du taux de montée (EA_CLIMB_FACTR). Il est recommandé de positionner un saut de quelques pas pour la limite basse et un saut plus faible pour la limite haute.

EA_ALTI_DEV - variable de configuration pour le mode de signalisation d'une déviation d'altitude. Elle contient la valeur de la hauteur choisie et du bit de passage en mode signalisation d'une déviation d'altitude.

EA_VOLUME - volume des messages vocaux et du signal du variomètre.

EA_COEF_AB0..10 - coefficients des équations de linéarisation de la courbe de variation de la pression (hPa) en fonction de l'altitude (m). La courbe est divisée en un ensemble de droites définies par h=a*P+b, où a et b sont des coefficients de droite 16 bits(a - octets 0..1, b - octets 2..3).

EA_PRESS_ZERO - valeur de la pression P0 [10 x Pa] enregistrée lors de la mise à zéro de l'altitude (durant l'initialisation). Cette valeur est utilisée pour le calcul de l'altitude (un algorithme basé sur la différence de pression est utilisé).

EA_OFFSET_GAIN - sauvergarde de la compensation et du gain utilisés pour la calibration du CAN. Ces valeurs sont déterminés lors de la calibration du CAN. Une valeur incorrect peut conduire à des mesures fausses et des problèmes avec le réglage des canaux de l'émetteur.

EA_SESION_NO - nombre incrémenté à chaque mise sous tension ou réinitialisation du SkyAssistant. Il correspond à un numéro de session dans le fichier d'enregistrement.

EA_FREQ_OFST - valeur de la déviation HF de l'émetteur par rapport à la fréquence du canal (l'émetteur travaille en synthèse de fréquence).

EA_CLIMB_OFST - compensation du taux de montée évaluée lors de la mise à zéro du variomètre (à l'initialisation). Cette compensation est ajoutée au signal utilisé pour le calcul de la vitesse verticale.


Configuration du variomètre

La fenêtre de configuration du variomètre permet de configurer le module variomètre du SkyAssistant. Par ailleurs, elle permet également de tester et de visualiser l'influence de ces paramètres sur le signal sonore final.

Variometer's configuration window

Offset du taux de montée - erreur de compensation du taux de montée. Valeur ajoutée au signal du variomètre pour l'initialiser à zéro. Cette valeur est déterminée à partir de paramètres statistiques issus des mesures de taux de montée et disponibles dans la fenêtre de statistique de mesures.

Le panneau de modification de signalisation du taux de montée (Sensibilité de signalisation du taux de montée) contient :

  • Sensibilité du taux de montée - sensibilité du variomètre. Le signal issu du module de mesure du SkyAssistant est divisé par cette valeur. Plus la valeur est élevée, plus la sensibilité est réduite. L'influence de la sensibilité du taux de montée sur le signal est visualisable sur le graphique. La valeur de sensibilité par défaut est de 1/12, ce qui permet de couvrir des taux de montée maximaux de 9,6m/s.

  • Constante du filtre du taux de montée - constante de temps du filtrage du taux de montée. Période de temps utilisée pour effectuer la moyenne des mesures du variomètre. Une constante de temps forte génère un comportement plus calme des variations du taux de montée, mais avec un retard plus important.

  • Zone supérieure d'insensibilité - limite supérieure de la zone de silence. Valeur de taux de montée au-dessus de laquelle le SkyAssistant basculera sur un signal sonore intermittent indiquant une montée. L'influence de ce paramètre sur le signal est visualisé sur le graphique sous forme d'un saut entre le zéro et le signal du taux de montée tracée en rouge.

  • Zone inférieure d'insensibilité - limite inférieure de la zone de silence. Valeur de taux de montée en-dessous de laquelle le SkyAssistant basculera sur le signal sonore continu indiquant une descente. L'influence de ce paramètre sur le signal est visualisé sur le graphique sous forme d'un saut entre le zéro et le signal du taux de montée tracée en bleu.

    Si la valeur du taux de montée est comprise dans la zone de silence, aucun signal audio ne sera émis. Ce système permet d'arrêter le signal sonore lorsque le modèle descend avec son taux de chute propre. Le signal sonore sera automatiquement rétabli dès que le modèle augmentera sa vitesse verticale (en montée ou en descente).

  • Le curseur Différence de son - taux de montée zéro (écart de son pour un taux de montée nul) définit la variation de fréquence au moment du passage par le taux de montée nul.

  • Volume sonore. C'est la valeur en pourcentage du volume sonore du variomètre.

    • Le panneau Paramètres d'interruption du son est utilisé pour définir la méthode d'interruption du son. Il a été décidé que les durées de signal sonore et de silence seraient identiques. Cependant, on peut faire varier la fréquence d'occurence des silences, la fréquence acoustique du son et l'évolution de ces paramètres en fonction du taux de montée.
    La variation du signal sonore est pilotée par l'équation T = -A * sound number + B. La droite correspondant à cette équation est tracée en vert sur le graphe.
    Un changement du coefficient A modifiera l'évolution de la durée du signal sonore et un changement du coefficient B modifiera la durée de silence. Après modification, il est recommandé de tester les nouveaux réglages en utilisant le panneau Test de sonorité.

    Le panneau Test de sonorité est utilisé pour tester le signal sonore du variomètre. Après avoir coché la case Test de sonorité, un curseur devient actif et permet de simuler une variation d'altitude. L'utilisateur entend le signal sonore associé au taux de montée déterminée par la position du curseur. Les tests réalisés au moyen du curseur n'ont aucune influence sur la configuration du variomètre.


Emetteur radio

Le fenêtre de configuration de l'émetteur est présentée ci-dessous :

Radio transmitter configuration

Le panneau de Fréquence contient :

  • l'information sur la bande radio utilisée, le canal et la fréquence de l'émetteur. Sont également affichées les valeurs de correction suivantes : compensation thermique et correction d'erreur de fréquence PLL.
  • le curseur Offset permet de modifier manuellement les fréquences dans les plages 250Hz ou 413Hz. Les modifications sont possibles dans un intervalle de +/- 0,5 pour chaque canal. Par défaut, ce réglage est désactivé. En effet, pour modifier l'offset de la fréquence, vous devez disposer d'un fréquencemètre de précision travaillant dans la bande RF jusqu'à une fréquence d'au moins 500MHz. Prière de me contacter pour accéder au contrôle de ce curseur.

    • Le panneau Générer un son contient :

  • une case à cocher Générer un son permettant de déclencher ou arrêter le générateur de son sur la fréquence choisie,
  • les boutons 2kHz, 1kHz, 600Hz permettent de choisir la fréquence du son généré.

    • Le générateur de son est utilisé pour régler finement l'émetteur de manière à obtenir un son clair et non déformé.

    Le curseur Volume pour le taux de montée est utilisé pour régler le volume du variomètre. Il peut être utilisé lorsque le récepteur radio ne dispose pas de réglage du volume ou si son amplitude de réglage n'est pas suffisante. Il n'a pas d'influence sur les messages vocaux. Par défaut, le volume doit être ajuster au niveau le plus élevé pour lequel aucune déformation du son n'est perceptible, en particulier dans les hautes fréquences (utiliser le générateur de son à 2kHz).
    Une description plus complète est fournie dans le chapitre Synthétiseur de son.

    Tous les changements effectués sur cette fenêtre sont envoyés au variomètre en temps réel. Le bouton OK valide les changements, le bouton Annuler les abandonne.


Configuration de l'enregistreur

Logger configuration window

La fenêtre de configuration de l'enregistreur permet de gérer la mémoire de l'enregistreur. On peut y fixer les canaux de mesure, les périodes de temps, lire et effacer le registre de la mémoire.

Différents éléments sont accessibles :

Panneau Données à enregistrer - contient les cases à cocher permettant de choisir une sélection de canaux de mesure qui seront écrits dans le registre de la mémoire.

Panneau Périodicité d'enregitrement - contient les cases à cocher permettant de choisir les temps d'enregistrement (temps entre chaque écriture en mémoire). Il est également possible d'arrêter l'enregistrement (Pas d'enregistrement).

Bouton OK - permet de fermer la fenêtre et de confirmer les changements.

Bouton Annuler - permet d'annuler tous les changements.

Charger un enregistrement - permet de lire le fichier d'enregistrement à partir de la mémoire du SkyAssistant sous forme de fichier binaire. Seules les pages marquées comme "écrites" seront lues. Pour lire à nouveau des parties de la mémoire précédemment lues, il faut cliquer sur le bouton Set unread. Ce bouton est inactif tant que l'état de la mémoire n'est pas rafraichi.

Conversion d'un enregistrement - convertit le fichier binaire en un fichier texte au format .VGD. La progression de la conversion est affichée dans la barre de progression en bas de la fenêtre.

Mettre au statut "non lu" - change le statut de toutes les pages mémoires en "non lu". Grâce à cette opération, la même page peut être lue plusieurs fois.

Effacer les enregistrements - efface tous les enregistrements. La progression de l'effacement est affichée dans la barre de progression en bas de la fenêtre.

Enregistrer la c onfiguration - écrit la configuration courante du SkyAssistant (ce qui provoque un changement du statut de l'enregistreur). Le bouton OK a le même effet (mais ferme en plus la fenêtre).

Actualiser le graphe mémoire - lit à nouveau le statut de toutes les pages mémoire (cela peut prendre plusieurs secondes). La progression est affichée dans la barre de progression. Le processus est lancé automatiquement à l'ouverture de la fenêtre. Une fois cette fenêtre ouverte, on peut relancer cette fonction aussi souvent que nécessaire.

La case à cocher Pas d'enregistrement en connection USB permet d'arrêter l'enregistreur lorsque le SkyAssistant est connecté au port USB. En effet, durant cette connection, l'enregistrement n'est en général pas nécessaire, car la session USB n'enregistre pas de données liées au vol. Ainsi, les sessions non utiles ne sont pas enregistrées.

Le panneau Description contient : les adresses mémoire de début et de fin de l'enregistrement courant et la mémoire libre en espace et en temps. Cette information évolue de manière dynamique en fonction des canaux de mesure et des périodes d'enregistrement.

Le graphique Statut mémoire présente une carte de l'occupation de la mémoire. Chaque carré représente une page de 512 octets. La légende des couleurs permet d'identifier le contenu de chaque page mémoire.


Configuration de l'émission des messages vocaux

La fenêtre de configuration des messages vocaux permet de définir la méthode d'émission des messages, la variation du signal PPM, le délai entre deux annonces et les paramètres dont les variations déclencheront l'émission d'un message vocal.

window of pronounciation configuration

Les éléments suivants sont accessibles par cette fenêtre :

Onglets Altitude, Tension et Température - sont utilisés pour choisir le paramètre à configurer.

Panneau par changement de valeur - permet de sélectionner les valeurs de déclenchement des messages vocaux.

Panneau par commande PPM - permet de sélectionner les variations du signal PPM déclenchant les messages vocaux (émission des messages lorsque la valeur du signal PPM varie de la valeur sélectionnée).

Panneau Periodicité - permet de sélectionner la valeur du signal PPM permettant une émission périodique des messages vocaux. Cela signifie que la périodicité des messages sera active uniquement les valeurs de signal PPM sélectionnée (-100% ou 0% ou 100%). Cette fonctionnalité peut être utile lor d'une spirale dans un thermique peu puissant : l'annonce de l'altitude aide à estimer la valeur du taux de montée. La périodicité du message est sélectionnée dans le panneau Communicate period.

Panneau Périodicité des communications - permet de sélectionner la périodicité d'émission des messages. En plus des valeurs prédéfinies, un champ texte permet d'entrer des valeurs personnalisées. Attention de ne pas entrer une période plus courte que la durée des messages, car sinon, le SkyAssistant n'émettra qu'un seul message.

Panneau Prononciation d'un message - contient des boutons permettant de déclencher des messages vocaux prédéfinis afin de valider les changements effectués.
Le champ texte Temps minimal entre deux annonces d'altitude et de tension [s] définit le délai entre les messages d'altitude et de tension et permet d'éviter de recevoir trop de messages d'un coup. Ce paramètre ne concerne pas les messages déclenchés manuellement par variation du signal PPM. Les valeurs autorisées s'étendent de 0 à 120s.

Le curseur Interruption de communication vocale permet de définir l'écart entre chaque mot d'un message, ce qui rend le message plus compréhensible.

Le curseur Volume sonore permet d'ajuster le volume sonore des messages vocaux.

OK - un appui sur ce bouton permet de fermer la fenêtre de configuration en sauvegardant les réglages et changements effectués.

Annuler - un appui sur ce bouton permet de fermer la fenêtre de configuration en abandonnant les changements effectués.


Configuration des évènements PPM

La fenêtre de configuration des évènements PPM défini les évènements déclenchés par un interrupteur 3 positions.

PPM events configuration

Le panneau Communication par déclenchement sur front contient deux sous-panneaux contenant des informations sur les messages vocaux déclenchés par un changement de l'interrupteur 3 positions :

  • 0% -> +100% - définit les messages vocaux déclenchés par le passage de l'interrupteur de la position neutre (0%) à la position positive maximale (+100%) du signal PPM,
  • 0% -> -100% - définit les messages vocaux déclenchés par le passage de l'interrupteur de la position neutre (0%) à la position négative maximale (-100%) du signal PPM.

    Le panneau Comportement sur front contient 3 sous-panneaux contenant des informations sur le comportement du SkyAssistant en fonction de la position de l'interrupteur PPM :

  • +100% = signal PPM à sa valeur positive maximale,
  • 0% = signal PPM à sa valeur neutre,
  • -100% = signal PPM à sa valeur négative maximale.

    • Les cases à cocher définissent ce que le SkyAssistant doit faire pour la position courante de l'interrupteur PPM : il peut émettre ou arrêter le signal du variomètre, les communications automatique et les messages périodiques.

    Même si les communications sont désactivées, les alarmes et les messages déclenchés sur changement de la position de l'interrupteur PPM continueront à être diffusés.

    Certains radiocommandes disposent d'interrupteurs à 2 positions seulement. En utilisant le réglage de fin de course dans la configuration de la radiocommande, il est possible de définir une valeur de signal pour les deux positions de l'interrupteur. Par exemple, sur un émetteur Hitec Eclipse, pour définir l'interrupteur "train" (voie 5 - en mode Acro) ou l'interrupteur "gaz" (voie 3 - en mode Planeur), il faut entrer 0% pour une position d'interrupteur et 100% sur l'autre position. Entrer 100% sur les deux positions d'interrupteur conduira à un basculement de +100% à -100% et aucun message du panneau Communication par déclenchement sur front ne sera déclenché ; ne seront déclenchés que les messages définis dans le sous-panneau Comportement sur front pour les valeurs de +100% et -100%.
    Faire attention de ne pas régler une valeur entre 0 et 100%. En effet, si l'on programme une valeur de 50% pour une des deux positions de l'interrupteur, cela causera la détection de nombreux basculements d'état à cause du bruit du signal PPM : des messages seront alors émis de maniètre ininterrompue si certains ont été définis !


Alertes

Une fenêtre de dialogue est utilisée pour régler les seuils d'alerte sur les grandeurs mesurées et les interférences du signal PPM.

Alerts configuration window

Le curseur Alerte tension basse permet de fixer le seuil d'alarme de la tension. Lorsque la tension mesurée descend en-dessous de ce seuil, un message vocal d'alerte est émis (message composé du mot "Attention" suivi de la valeur de la tension). Une large gamme de tensions est acceptée, ce qui permet un grand nombre de possibilités de sources d'alimentation du SkyAssistant. On peut utiliser de 1 à 3 éléments Li-XX ou de 4 à 9 éléments Ni-XX.

Le curseur Alerte température haute permet de fixer le seuil d'alarme de la température. Si la température mesurée s'élève au-dessus de ce seuil, un message vocal d'alert est émis (message composé du mot "Attention" suivi de la valeur de la température). Cette alarme est utilisée principalement pour contrôler la température de la chaine de propulsion comme les batteries d'alimentation ou le moteur.

Le curseur Alerte altitude permet de fixer le seuil d'alarme de l'altitude. Lorsque l'altitude mesurée est supérieure à ce seuil, un message vocal d'alert est émis (message composé du mot "Attention" suivi de la valeur de l'altitude). Cette alarme peut être utilisée sur les terrains où l'altitude autorisée pour les modèles R/C est plafonnée ou lors de remorquages pour larguer à une altitude maximale.

Le curseur Alerte PPM permet de fixer un seuil acceptable d'erreurs PPMs. Une erreur PPM signifie que la largeur d'une impulsion est inférieure à 0.75ms et supérieure à 2.25ms et que le délai entre deux impulsions est inférieure à 10ms et supérieure à 25ms.
Le nombre d'erreurs est calculée sur une période de 1s, ce qui explique le léger retard (moins de 1s) de début de message d'alerte.

En cas de situation permanente d'alerte, un message est émis toutes les 20s afin de ne pas bloquer les autres fonctions du SkyAssistant.

Le panneau Paramètres du signal PPM contient les curseurs utilisés pour définir les paramètres du signal d'alerte. Trois curseurs sont disponibles :

  • Nombre de bips - nombre de bips dans le message. La valeur par défaut est 4.
  • Tonalité - permet de définir la fréquence du signal. Comme les hautes fréquences sont rares, elles contrastent bien avec le signal du taux de montée lorsque celui-ci est faible.
  • Durée du bip - détermine la durée d'un bip et la durée du silence entre deux bips (durées identiques). De petites valeurs de durée sont recommandées, afin de reconnaitre plus facilement le signal en comparaison avec le signal du taux de montée.

    • Le panneau Test d'alerte contient un ensemble de boutons permettant d'écouter les alarmes. Dans le cas de messages vocaux, les messages contiendront les paramètres mesurés au moment de l'écoute.


Traitement des données enregistrées

Log processing window

Cette fenêtre permet à l'utilisateur de définir la méthode de traitement des données enregistrées, traitement réalisé lors de la conversion du fichier binaire (lu à partir de l'enregistreur) en fichier texte .VGD.

Le panneau Taille des filtres moyenneur contient deux curseurs utilisés pour définir la taille des filtres (nombre de données prises en compte pour le calcul de la moyenne) sur l'altitude ou le taux de montée. Le calcul de moyenne permet d'obtenir des courbes plus lissées. Plus le filtre est de grande taille, plus le graphe sera lissé, mais au prix d'un glissement du graphe vers la droite (décalage temporel). La valeur 1 permet de ne pas activer le filtre.


Profil de température

Le fenêtre de configuration du profil de température atmosphérique se présente de la manière suivante :

atmosphere temperature profile configuration

Cette fenêtre comporte deux curseurs :

Le curseur Gradient thermique adiabatique est utilisé pour définir la référence du profil (line fine couleur cyan débutant à l'extrémité supérieure de l'axe vertical des altitudes) et montrant comment la température décroit en fonction de la hausse d'altitude, décroissance générée par l'expansion adiabatique de l'air chaud montant. En fonction du taxu d'humidité de l'air, le gradient thermique adiabatique peut prendre des valeurs comprises entre 0,56 (air humide) et 0,98 °C/100m (air sec). L'atmosphère standard CIAO utilise une valeur de 0,649 °C/100m.

La case à cocher Afficher gradient thermique adiabatique permet ou non l'affichage du profil de référence sur le graphique.

Le curseur Epaisseur couche limite permet de fixer la limite basse d'altitude à partir de laquelle le profil de température sera calculé. Très souvent, en l'absence de nuages, le planeur au sol, exposé au soleil, se réchauffe beaucoup plus que l'air ambiant. A la mise sous tension du SkyAssistant, ces températures initiales élevées faussent le calcul du profil de température.

Le phénomène est décrit sur les figures suivantes :

wrong profile

Les températures élevées initiales génèrent les points de mesure entourés en rouge sur le graphique.
Dans ce cas, les températures au sol sont donc prises en compte dans l'élaboration du profil de température.
La variation de température en fonction de l'altitude est de -1,30°C/100M.

correct profile

Dans ce second cas, la prise en compte des températures ne se fait qu'à partir de 10m au-dessus du sol.
Cette fois, les valeurs faussées ne sont pas prises en compte.
La variation de température en fonction de l'altitude est de -0,23°C/100m.

Echange adiabatique - aucun échange de chaleur avec l'environnement n'est pris en compte.


Signalisation d'une déviation d'altitude

Cette fenêtre de dialogue permet de définir un mode de travail signalant toute déviation par rapport à une altitude donnée. Cette fonction aide à conserver le modèle à une hauteur choisie (par rapport à l'altitude de décollage). Lorsque le modèle est sous l'altitude fixée, le SkyAssistant émettra un signal de descente. Lorsque le modèle est au-dessus de l'altitude fixée, le SkyAssistant émettra un signal intermittent signalant une montée. La fréquence du signal sonore est proportionnelle à la valeur de déviation. Si le modèle reste dans le domaine fixé (+/-), aucun signal ne sera émis.

Altitude deviation signalling configuration window

Le champ Valeur demandée est utilisé pour choisir la hauteur relative par rapport à l'altitude de décollage, hauteur qui doit être conservée par le modèle. Cette hauteur peut être une valeur positive ou négative avec une résolution de 0,1m.

Les curseurs Limite haute d'insensibilité et Limite basse d'insensibilité sont utilisés pour définir la zone de silence dans laquelle aucun message de déviation ne sera émis. Cet intervalle est commun pour la déviation d'altitude et la signalisation du taux de montée.

Le panneau Signalisation sonore propose deux options :

  • singalisation du taux de montée,
  • signalisation de la déviation d'altitude.

    • Le basculement entre ces deux options nécessite un re-démarrage du SkyAssistant, ce qui est fait automatiquement après appui sur le bouton OK.

    Le bouton OK prend en compte les changements et s'il y a lieu, affiche une fenêtre de confirmation. Le SkyAssistant sera redémarrer en cas de confirmation.

    Le bouton Annuler annule les changements réalisés et retourne à la fenêtre de configuration précédente.


Menu de gestion des messages vocaux

Ce menu contient les commandes suivantes :

Lire message... - permet la lecture des messages vocaux du SkyAssistant à des fins de contrôle.

Sauvegarder message... - permet d'envoyer au SkyAssistant un fichier compilé des messages vocaux. Cette commande est utilisée pour remplacer des messages par des nouveaux ou pour corriger des messages endommagés.

Compiler un ensemble de fichiers... - permet la compilation des messages au format .WAV en un seul fichier qui sera écrit dans la mémoire du SkyAssistant. La compilation effectue les opérations suivantes : effacement de l'entête .WAV, ajout de l'index des fichiers de message et sauvegarde dans le nouveau fichier. Ainsi, chaque message vocal commence sur une nouvelle page de la mémoire (adresse divisée par 512).

Modifier les commandes vocales... - permet d'écouter et de remplacer des messages dans la mémoire du SkyAssistant.


Commandes de modification des messages vocaux

Ces commandes permettent d'écouter et de changer les messages vocaux (au format .wav).

Le fichier correspondant à un message vocal doit être au format approprié : mono, 8kHz, 8 bits.

Si l'utilisateur souhaite utiliser des messages plus longs, il doit les compiler en un nouveau fichier .SAW et charger ce dernier dans le SkyAssistant. C'est un processus très lourd en temps nécessaire.

Testowanie i modyfikacja sampli

Les informations disponibles dans la fenêtre ci-dessus sont les suivantes :

La liste des messsages contient :

  • le numéro de message,
  • le nom du fichier contenant le message, extrait du fichier sample.txt,
  • l'adresse en mémoire du début du message,
  • la taille en octets du message,
  • le taux de remplissage de la mémoire : taille du message / (nombre de pages mémoire utilisées * taille de la page mémoire).

    ATTENTION ! pour sélectionner un message particulier, il faut cliquer sur le nom de ce message. Les autres champs ne permettent pas la sélection.

    Changer msg. - ouvre une page de dialogue pour charger un nouveau fichier à la place du fichier sélectionné.

    Prononciation - joue le message sélectionné.

    Changer le chemin d'accès - permet le changement de chemin d'accès au répertoire contenant le fichier sample.txt. Le chemin d'accès est rappelé dans le champ situé en bas de la fenêtre.


Menu Test

Les commandes disponibles dans ce menu sont utilisées essentiellement pour le diagnostic du SkyAssistant.

Dans la version finale du SkyAssistant, ce menu sera supprimé. Certaines commandes concernent des tests temporaires ou des tests bas niveau du logiciel, ce qui les rendent peu utiles pour l'utilisateur. Ces commandes sont donc peu documentées.

Mesures statistiques - affiche une fenêtre de dialogue avec une analyse statistique des signaux mesurés. L'utilisation de ces résutats permet de déterminer le "zéro" du taux de montée.

Calibration convertisseur A/N - permet la clibration manuelle du Convertisseur Analogique Numérique (CAN). En principe, le CAN est calibré automatiquement à chaque initialisation du SkyAssistant.

Test message altitude - ouvre la fenêtre de test d'émission des messages vocaux liés à l'altitude.

Test transmission - permet le test des fonctions. Cette commande lance un test de transmission sur le port série entre le logiciel et le SkyAssistant.


Statistique des mesures

Measurements statistics window

Cette fenêtre est utilisée pour effectuer une analyse statistique des données mesurées. Elle permet de déterminer le niveau de bruit dans les mesures grâce aux informations suivantes : moyenne quadratique, variance et écart type du signal mesuré, en condition de test.

Lors des mesures, il est recommandé d'éviter toutes perturbations pouvant impacter les paramètres mesurés. Le SkyAssistant doit être posé de maniètre stable et les fenêtres ou portes doivent être fermées pour éviter le vent ou les courants d'air. Il est recommandé d'effectuer plusieurs séries d'enregistrement avec les portes / fenêtres ouvertes et fermées pour constater les écarts.

Les éléments disponibles dans la fenêtre statistique sont les suivants :

La fenêtre de saisie Nombre d'échantillons détermine le nombre d'enregistrements dans une série de mesures. La valeur par défaut est 1000. On peut choisir une valeur entre 100 et 10000.

La fenêtre de saisie Température permet d'entrer la température réelle lors du test, température utilisée pour la compensation des capteurs de température. La valeur initiale contenue dans cette fenêtre de saisie, à l'ouverture de la fenêtre statistique, est la température moyenne des deux capteurs (interne et externe).

Le panneau Résultats de mesures contient la liste des paramètres mesurés et leurs valeurs statistiques. Les colonnes contiennent les informations suivantes :

  • nom et unité de mesure du paramètre,
  • valeur moyenne,
  • variance,
  • écart type.

    • Le panneau Compensation d'erreurscontient la liste des valeurs pour lesquelles une correction d'erreur est effectuée. Les colonnes contiennent les informations suivantes :

  • nom et unité de mesure du paramètre,
  • erreur entre la valeur moyenne de l'enregistrement et la valeur entrée par l'utilisateur (erreur de compensation),
  • valeur de la compensation utilisée.

    Le bouton Réglage offset du taux de montée est actif lorsque la session de mesure est terminée. Il fixe la valeur de compensation du taux de montée en prenant en compte le résultat de la dernière série de mesures. Pour régler le plus précisément possible le zéro, il est recommandé d'utiliser la période de mesure la plus longue.

    Le bouton Démarrage lance les mesures. Une fois que la série est lancée, elle ne peut plus être stoppée avant qu'elle ne soit finie.

    Le bouton Effacer les résultats efface les résultats contenus dans la fenêtre.


Calibration du convertisseur analogique / numérique (CAN)

La fenêtre de calibration du CAN se présente de la manière suivante :

Calibration window

  • Panneau Histogramme - contient l'histogramme de GND (tracé bleu), associé à la plus petite valeur mesurée, et l'histogramme de VRef (tracé rouge) associé à la plus haute valeur mesurée. La ligne située en haut du graphique permet d'afficher le résultat en pourcentage des mesures (c'est à dire le nombre de mesures sur l'histogramme correspondant). Le reste des mesures est situé hors du domaine du CAN.

  • Les curseurs Offset & Gain sont utilisés pour le réglage manuel de ces paramètres. Déplacer le curseur vers la droite déplace le résultat des mesures (après leur exécution) vers la droite également (même fonctionnement vers la gauche). Les valeurs de compensation et de gain sont sauvegardées dans la variable EA_OFFSET_GAIN et sont appelés lors de chaque mise sous tension du SkyAssistant.

  • Le bouton OK ferme la fenêtre et confirme les changements, le bouton Annuler ferme la fenetre et annule tous les changements.

  • Le bouton Générer l'histogramme lance les séries de mesures de GND et de VRef et affiche le résultat des ces mesures sur l'histogramme.

    • La méthode de calibration est décrite dans un autre chapitre.


Test du générateur de message vocal

Altitude messages testing window

L'ouverture de cette fenêtre fait basculer le SkyAssistant en mode "diagnostic" dans lequel on peut simuler des variations d'altitude, ce qui permet de générer le message vocal correspondant.
La fermeture de la fenêtre fait basculer le SkyAssistant dans le mode de travail normal.

Cette fenêtre comporte un curseur pour fixer l'altitude. L'altitude choisie est affichée sous forme numérique.

Appuyer sur le bouton Prononciation d'un message déclenchera l'émission d'un message vocal pour toute valeur d'altitude, sauf si l'altitude est réglée sur les valeurs multiples de la valeur de variation d'altitude définie dans la fenêtre de configuration de l'émission des messages vocaux. Par défaut, ces valeurs sont des multiples de 50m : 50, 100, 150...


Test de transmission

Le test consiste en l'envoi de 1000 trames de données entre le SkyAssistant et l'ordinateur PC. Une fois le test achevé, les résultats sont affichés avec la vitesse réelle de transfert des données, le temps de transmission et le nombre d'erreurs relevées.

Transmission test results window

La vitesse de transfert et le nombre d'erreurs dépendent de la charge CPU courante du SkyAssistant. C'est pourquoi il est recommandé d'arrêter l'enregistreur et le générateur vocal lors des transferts de gros voulmes de données, afin de décharger le microcontroleur et lui permettre de disposer de plus de ressources CPU.


Menu d'aide

Ce menu ouvre une fenêtre contenant les informations suivantes :

About box

Sont affichées la version du logiciel et du microcontrôleur, le numéro de série du SkyAssistant, le numéro d'identification du matériel (qui est une "synthèse" des numéros de série des puces électroniques contenues dans le SkyAssistant).
Afin de pouvoir lire la version du microcontrôleur et le numéro de série, il faut connecter le SkyAssistant à l'ordinateur.

Si aucune communication n'est établie avec le SkyAssistant, le message suivant apparaît :

About - without communication


Codes d'erreur

L'application wario.exe utilise plusieurs codes d'erreur. Ces codes sont affichés dans la barre de status.

La signification des codes est la suivante :

Nr | Erreur | Description
0 | ERR_OK | Aucune erreur
1 | ERR_NOT_CONNECTED | Absence de connexion au port Série
2 | ERR_CANT_CONNECT | Ne parvient pas à se connecter au port Série
3 | ERR_INVALID_DATA_SIZE | Taille de donnée incorrecte dans la trame
4 | ERR_INVALID_COMMAND | Commande invalide
5 | ERR_SEND_DATA | Erreur d'envoi de donnée
6 | ERR_RECEIVE_FILE | Erreur de réception de donnée
7 | ERR_HEADER | Entête de trame invalide
8 | ERR_COMMAND | Commande invalide
9 | ERR_CRC | Erreur de CRC
10 | ERR_PROT_STATE | Etat invalide du protocole de transmission
11 | ERR_ABORT_SAVE | Annulation de sauvegarde de fichier
12 | ERR_NO_FILE | Fichier non trouvé
13 | ERR_FILE_READ | Erreur de lecture de fichier
14 | ERR_SEEK_FILE | Erreur de position du fichier
15 | ERR_TIMEOUT | Timeout de réception des données
16 | ERR_DATA | Donnée invalide
17 | ERR_NO_DATA_RECEIVED | Aucune donnée reçue
18 | ERR_OPEN_PORT | Le port ne peut être ouvert
19 | ERR_CONNECTED | Déjà connecté

Durant la communication avec le logiciel, le SkyAssistant peut renvoyer une trame présentant des erreurs. Dans ce cas, des paramètres additionnels sont envoyés et contiennent le code d'erreur.
Nr | Error | Description
200 | ERR_DATA_COUNT | Nombre de données invalide
201 | ERR_CRC | CRC de commande invalide
202 | ERR_COMMAND | Numéro de commande invalide
203 | ERR_VERIFY | Erreur de vérification d'écriture dans l'EEPROM
204 | - | La valeur 204 correspond à des données non initialisées dans VC++. Merci de ne pas l'utiliser pour définir une erreur
205 | ERR_EXECUTE | Retour d'erreur de la commande en cours
206 | ERR_MESSAGE_END | Fin du message d'erreur

Lorsqu'une commande appelée (via l'interface de communication) retourne un message d'erreur ERR_EXECUTE, un octet supplémentaire contenant le type d'erreur est envoyé :
Nr | Error | Description
100 | ERRP_POWER | Tension d'alimentation trop basse
101 | ERRP_OVWR_CONF | Les variables de configuration ont été écrasées par les valeurs par défaut
102 | ERRP_CANAL | Canal de transmission invalide
103 | ERRP_INCPL_CALIB | Calibration incomplète
104 | ERRP_ADRS_SIZE | Adresse de trame incorrecte ou erreur de lecture de la longueur ou de l'adresse de trame


Modules fonctionnels

Ce chapitre contient la description détaillée de chaque module fonctionnel (spécification fonctionnelle et configuration).

La version actuelle du SkyAssistant contient les modules fonctionnels suivants :

Variomètre
Altimètre
Thermomètre
Voltmètre
Enregistreur
Synthétiseur de son
Générateur vocal
Analyseur de signal PPM
Interface de communication
Emetteur radio
Interrupteur DIP
Convertisseur A/N


Variomètre

Le variomètre est le module chargé de la mesure de la vitesse verticale du modèle R/C (en montée et en descente) appelée par la suite "taux de montée". Il génère également un signal sonore (appelé par la suite "signal du vario") informant le pilote de la valeur et du signe du taux de montée.
Un taux de montée positif signale que le modèle est en train de monter et est signalé par un son intermittent dont le temps entre deux sons et la fréquence sont proportionnels au taux de montée. Plus le modèle monte rapidement, plus le son est aigu et l'intervalle entre deux "beeps" est court.
Un taux de montée négatif signale que le modèle est en train de descendre et est signalé par un son continu dont la fréquence est proportionnelle au taux de chute. Plus le modèle descend rapidement, plus le son est grave.

La sensibilité du variomètre peut être ajustée. La variable EA_CLIMB_FACTR est utilisée dans ce but.

La période de temps pendant laquelle les données enregistrées sont utilisées pour moyenner la valeur du taux de montéee peut également être ajustée. Plus cette période de temps est importante, plus le temps de réaction du variomètre est long et le son généré stable. La variable utilisée ici est EA_CLIMB_AVRG.

La zone de silence (zone représentative d'un intervalle autour d'un taux de montée nul et pour laquelle aucun son n'est généré) peut aussi être réglé. Elle est principalement utilisée pour éviter de désorienter le pilote lorsqu'aucune action n'est requise. La zone de silence peut être ajustée indépendamment dans sa limite haute et sa limite basse (taux de montée positif et négatif). Ces limites sont définies au moyen de deux variables: EA_UP_IS_ZONE et EA_DN_IS_ZONE.

La limite basse de la zone de silence peut être ajustée de manière à ce qu'aucun son ne soit généré lorsque le modèle descend avec son taux de chute naturel. La valeur retenue sera ajustée en fonction des vols enregistrés précédemment lorsque le modèle descend naturellement en atmosphère neutre).

free descending measurements

Sur le graphe, un passage particulier du vol est choisi. Le programme calcule automatiquement le taux de chute moyen sur cet intervalle. La limite basse de la zone de silence sera fixée sur cette valeur (voire une valeur plus faible). Ainsi, lors d'un vol normal en atmosphère neutre (sans ascendances), aucun son ne sera généré.

Lors de l'initialisation du SkyAssistant, le variomètre est remis à zéro avec la remise à zéro de la variable EA_CLIMB_OFST. Cette variable contient la valeur du taux de montée enregistrée lors des mesures statistiques du signal. Cette valeur est utilisée comme taux de montée nul. Au cours du vol, elle est soustraite du taux de montée mesuré.

En fonction des conditions extérieures (comme la température, le taux d'humidité, etc...), le signal du variomètre en conditions stables (au repos) peut être différent zéro. Afin d'éviter cette situation, un algorithme de remise à zéro a été ajouté. Il détecte lorsque le variomètre est au repos au sol, calcule l'offset et par pas réduits, compense cet offset jusqu'à ce que le variomètre indique un taux de montée nul.


Description de la mesure du taux de montée

Le taux de montée (ou vitesse verticale), d'un point de vue mathématique, est la dérivée première de l'altitude. Comme la résolution demandée pour la mesure du taux de montée est de 5cm/s et la résolution de la mesure d'altitude est de 1m, les mesures d'altitude ne peuvent être utilisées pour calculer le taux de montée et obtenir une résolution aussi fine que demandée.

Pour cette raison, les informations sont mesurées au moyen d'un circuit à base d'amplificateurs opérationnels.
La vitesse verticale est détectée par un module différentiel classique (à base d'amplificateurs, de résistances et de condensateurs). Ce module génère un signal dont la tension respecte l'équation suivante :

Uout = -RC dUin/dt

Pour l'étape suivante, ce signal entre dans le converisseur analogique / numérique où il est converti en une valeur numérique. Le reste du traitement est réalisé par le logiciel du microcontrôleur.

schemat blokowy wariometru


Ecart de son lors d'un taux de montée "nul"

Dans le cas où les limites haute et basse de la zone de silence sont nulles, le variomètre conitnuera à informer sur le taux de montée courant. Comme le génrateur de son fonctionne de manière linéaire, l'écart entre deux sons consécutifs sera minimal.

Lorsque le signal du variomètre oscille autour de la valeur zéro, il est difficile de reconnaitre un signal de descente interrompu d'une part, et un signal intermittent normal de montée d'autre part. Afin d'éliminer ce problème, une discontinuité a été implémentée dans la génération du signal, ce qui permet de séparer le signal de montée et celui de descente par un intervalle de son ajustable par l'utilisateur.
graph of vario signal incontinuity

Grâce à ce procédé, lorsque le signal passe par la valeur zéro, il y a un saut fréquentiel du son qui permet de reconnaître plus facilement la montée et la descente.
L'écart de son doit être suffisamment important pour permettre au pilote de reconnaître sans problème la montée et la descente, seulement par le timbre du son. La valeur peut être fixée par l'utilisateur dans la fenêtre de configuration du variomètre grâce au curseur Différence de son - taux de montée zéro et est enregistrée dans la variable EA_VSIG_DISC.

Une trop forte valeur a pour résultat une dynamique de signalisation plus faible ; en effet, une partie de l'intervalle de son disponible n'est plus utilisée.


Variable EA_CLIMB_FACTR

Cette variable permet d'ajuster la sensibilité du variomètre. Au niveau du matériel, la sensibilité disponible est supérieure à celle nécessaire aux applications modélistes. De plus, la forte amplification du bruit généré par le capteur peut perturber le signal de montée.

La valeur mesurée du taux de montée est divisée par la valeur de la variable EA_CLIMB_FACTR et la valeur alors calculée est renvoyée par le SkyAssistant. En augmentant la valeur de la variable, le diviseur est augmenté et la sensibilité du variomètre est réduite. A l'inverse, en diminuant la valeur de la variable, une sensibilité plus grande est obtenue.

La variable est codée sur 3 octets.
La valeur par défaut est 0x1301000A.

octet 3 | octet 2 | octet 1 | octet 0
STEP_CNT | MIN_VAL | N/C | CLIMB_FACTOR

CLIMB_FACTOR - valeur du taux de montée. Valeurs suggérées : 6..20
MIN_VAL - valeur minimale à choisir dans le menu de configuration.
STEP_CNT - un nombre de valeurs à choisir dans le menu de configuration.


Variable EA_CLIMB_AVRG

Cette variable définit le temps à partir duquel une valeur de taux de montée est généré. Elle définit physiquement la taille du filtre passe-bas en ajustant la période de coupure. Plus la période de coupure est élevée, plus l'intervalle des signaux utilisés pour le calcul de la moyenne est important.

La variable est codée sur 3 octets.
La valeur par défaut est 0x03000008.

octet 3 | octet 2 | octet 1 | octet 0
STEP_CNT | MIN_VAL | N/C | CLIMB_AVRG

CLIMB_AVRG - index de la période de coupure du filtre
MIN_VAL - valeur minimale à choisir dans le menu de configuration
STEP_CNT - un nombre d'index disponibles à choisir dans le menu de configuration.


Variables EA__xx_IS_ZONE

Variables EA_DN_IS_ZONE & EA_UP_IS_ZONE

Ces variables définissent les limites inférieure et supérieure de la zone de silence du variomètre (intervalle de valeurs de taux de montée, pour lequel aucun signal n'est émis).

La variable est codée sur 3 octets.
Les valeurs par défaut sont 0x14000004 pour la limite supérieure et 0x14000020 pour la limite inférieure.

octet 3 | octet 2 | octet 1 | octet 0
STEP_CNT | MIN_VAL | N/C | IS_ZONE

IS_ZONE - valeur de la zone de silence pour laquelle le variomètre est silencieux.
MIN_VAL - valeur minimum à choisir dans le menu de configuration.
STEP_CNT - un nombre de valeurs disponibles à choisir dans le menu de configuration.


Variable EA_CLIMB_OFST

Cette variable est utilisée pour ajuster le "zéro" du signal du variomètre (mise à zéro du taux de montée). Sa valeur est ajustée conformément aux mesures statistiques afin de la rendre nulle lorsque la valeur est déduite du signal.

La variable est codée sur 2 octets (les octets 2 et 3 ne sont pas utilisés).
Elle n'a pas de valeur par déaut. Les valeurs sont bornées par l'intervalle [-32767,32767] (0x8001..0x7FFF).

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | CLIMB_OFST_H | CLIMB_OFST_L


Variable EA_VARIO_RCk

Cette variable contient les valeurs physiques du module différentiel comme la résistance dans le circuit de feedback, l'impédance dans le module d'entrée et l'amplification du second amplificateur du module. Ces valeurs sont nécessaires pour le calcul de la valeur de l'estimation de la vitesse verticale par le logiciel.

La variable est codée sur 3 octest (l'octet 3 n'est pas utilisé).
La valeur par défaut est 0x0012217C.

octet 3 | octet 2 | octet 1 | octet 0
N/C | k | C | R

R - 10 * valeur de la résistance (MΩ)
C - 10 * valeur de la capacité (μF)
k - 10 * amplification


Altimètre

Le SkyAssistant est équipé d'un altimètre mesurant la variation de pression en fonction de l'altitude. Le formule reliant l'altitude et la pression est la suivante :

relation between pressure and altitude

où :

p0 - pression mesurée au cours du vol en Pascal [Pa]
p1 - pression de référence mesurée à l'altitude de mise sous tension du SkyAssistant [Pa]
R - constante des gaz parfaits et égale à 287,052 [J/(K*kg)]
g - gravité, égale à 9,81[N/m2]
0,0065 [K/m] - variation de la température en fonction de l'altitude

graph of relation between pressure and altitude

Tracés de la courbe d'altitude [m] en fonction de la différence de pression (P0-P1) [kPa] et de la courbe obtenue par la méthode d'approximation (voir ci-dessous).

Comme une telle relation est trop compliquée à calculer avec un processeur 8 bits, une méthode d'approximation par droites multiples est utilisée. Du fait de cette simplification, ces courbes sont associées à des plages de pression constante. La taille des plages a été déterminée de manière à ce que cela donne une erreur faible (inférieure à 1 m) en basse altitude. La fonction h(p) n'étant pas linéaire, cette erreur croît pour atteindre une erreur légèrement supérieure à 2 m pour une altitude de 4000 m.

La courbe ci-dessous trace l'erreur en altitude en fonction de la pression :

Tracé de l'erreur générée par la méthode d'approximation exprimée en mètres en fonction de la différence de pression (p0-p1) [kPa]

L'altitude est calculée relativement au point pour lequel le zéro de l'altimètre a été établi (pour être plus exact, il faudrait parler de "hauteur"). Cela est effectué automatiquement après la mise sous tension du SkyAssistant.

L'altitude est mesurée avec une résolution de 1m par les circuits électroniques, mais est affiné à 0,1m près en utilisant des méthodes statistiques.
La précision de mesure dépend de plusieurs paramètres. La principale limitation est la précision du capteur (1.5%).

Il est possible de mesurer des hauteurs négatives. L'amplitude de mesures possibles des hauteurs est de +-3000m.

Les mesures issues du capteur de pression peuvent dériver environ 20 minutes après la mise sous tension du SkyAssistant, ce qui provoque une dérive de l'altitude dans le temps. Afin de résoudre ce problème, un algorithme d'annulation de la dérive a été implémenté.
L'altimètre détecte les situations où le SkyAssistant repose sur le sol, calcule l'erreur de compensation d'altitude et la sosutrait de l'altitude mesurée.


Mesure de l'altitude

Le système de mesure de l'altitude peut être décrit de la manière suivante :

altimeter block graph

Ce système fonctionne comme suit :

Afin d'augmenter la résolution de la mesure, l'intervalle de travail du capteur de pression est adapté aux valeurs classiquement obtenues lors du vol des planeurs R/C. Ce résultat est obtenu par soustraction (en utilisant une circuit analogique) une tension constante (2.1739V) de la tension générée par le capteur de pression. L'intervalle de tension s'étend de 4.7V (pour les hautes pressions au niveau du sol) à 0.2V (pour des pressions à 7700m d'altitude). Cette méthode permet une meilleur résolution qu'en utilisant la méthode classique où le signal issu du capteur passe au travers d'un diviseur avant de parvenir au CAN, Elle rend possible l'utilisation de la plage complète du CAN sans diminuer la résolution de la mesure. Cependant, ce résultat est obtenu au prix d'une intervalle de mesure plus faible : jusqu'à 2.5V au lieu de 4.5V, ce qui correspond à mesurer des altitudes inférieures à 4200m.

Après traitement (comme signalé ci-dessus), le signal parvient au CAN, où il est converti en une valeur 12 bits. Afin d'améliorer la précision de mesure, le signal est suréchantillonné. Le suréchantillonnage est obtenu par échantillonnage multiple, puis les résultats sont sommés et moyennés. La sommation et le moyennage sont effectués afin d'obtenir une valeur de sortie du signal 10 fois supérieure à la valeur d'entrée. Ce mécanisme est utilisé pour augmenter la résolution de lecture. Le module de mesure effectue les calculs avec des entiers et fournit un résultat 10 fois supérieur à la valeur physique ; le module de sortie déplace ensuite le symbole décimal d'une position vers la gauche ajoutant ainsi la fraction décimale (un chiffre après le symbole décimal, à savoir la un chiffre après la virgule).

L'étape suivant consiste à calculer la pression courante. La variable EA_PRESS_ZERO (valeur de la pression au moment de la mise à zéro du SkyAssistant) est soustraite à la valeur de la pression mesurée. Le résultat est donc l'écart entre la pression courante et la pression initiale.
Cet écart de pression est ensuite utilisé pour le calcul de l'altitude qui est simplifié par l'utilisation de 13 équations linéaires de type h=A*p+B. Le résultat est alors divisé par 10 afin d'obtenir la valeur de l'altitude mesurée.
Lors de cette étape, aucune compensation en température n'est utilisée. Les constantes A et B sont fixées pour une température donnée, ce qui rend possible la création d'un ensemble de constantes associées à différents niveaux de température. En disposant de la pression et de la température enregistrées, il est alors possible de calculer en temps différé l'altitude réelle corrigée.


Signalisation d'une déviation d'altitude

SkyAssistant dispose d'un mode spécial permettant au pilote d'un modèle motorisé de garder une altitude constante par rapport au point de départ. Ce mode est appelé "Signalisation de déviation d'altitude".
Dans ce mode, SkyAssistant utilise la même méthode qu'en mode variomètre pour signaler toute variation par rapport à l'altitude fixée par l'utilisateur.

Si le modèle monte plus haut que l'altitude fixée, un son ascendant intermittent le signalera (comme dans un thermique) avec un volume proportionnel à l'intensité de la variation.

Si le modèle descend sous l'altitude fixée, le son sera descendant et continu (comme dans une zone descendante).

Aucun son ne sera généré si le modèle reste à l'atitude choisie.

Il n'est pas possible d'utiliser simultanément ce mode et le mode variomètre ou de basculer de l'un à l'autre en cours de vol. Pour changer de mode, il est nécessaire de redémarrer SkyAssistant.


Variable EA_PRESS_ZERO

Cette variable contient la valeur sur 24 bits de la pression mesurée lors de l'initialisation en altitude. Elle est déterminée automatiquement : ne la modifiez pas !
La variable est codée sur 3 octets (l'octet 3 n'est pas utilisé).

Octet 3 | Octet 2 | Octet 1 | Octet 0
not used | press_zeroH | press_zeroM | press_zeroL


Variable EA_COEF_AB0..10

Cette variable contient les valeurs des facteurs A et B utilisés pour la linéarisation de la courbe de variation de la pression.
La variable est codée sur 4 octets. Actuellement, 11 jeux de facteurs sont utilisés. Le basculement d'un jeu de facteurs à l'autre est automatique en fonction de la variation de la valeur des différences de pression.

octet 3 | octet 2 | octet 1 | octet 0
coef_BH | coef_BL | coef_AH | coef_AL

coef_AH..L - valeur du facteur A
coef_BH..L - valeur du facteur B


Variable EA_ALTI_DEV

Cette variable stocke la valeur de la déviation d'altitude, ainsi que le bit permettant le démarrage du SkyAssistant dans le mode "Signalisation de déviation d'altitude".

La variable est codée sur 4 octets (l'octet 3 n'est pas utilisé).
La valeur par défaut est égale à 0x00000064 (10,0m)

octet 3 | octet 2 | octet 1 | octet 0
NC | mode | alt_H | alt_L

mode - le bit de poids faible de l'octet permet le passage en mode "signalisation de déviation d'altitude". Pour démarrer dans ce mode, il est nécessaire d'effectuer un redémarrage du SkyAssistant.
alt_H..L - octet de poids faible et octet de poids fort de l'altitude en mètres * 10 (par exemple, 0x7D = 125 = 12,5m)


Variable EA_ALARM_ALTI

Cette variable garde en mémoire la valeur de l'alarme "altitude maximale".

La variable est codée sur 4 octets (les octets 2 et 3 ne sont pas utilisés).
La valeur par défaut est 0x00003A98 (1500,0 m) pour le système métrique.
La valeur par défaut est 0x0000AFC8 (4500,0 ft) pour le système impérial

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | alarm_H | alarm_L

alarm_H..L - l'alarme "altitude maximale" sera déclenchée lorsque l'altitude atteinte sera supérieure à cette valeur


Thermomètre

Le SkyAssistant est équipé de deux thermomètres :

  • un thermomètre interne, physiquement placé dans le microcontrôleur qui mesure la température du SkyAssistant,
  • un thermomètre externe, connecté à la prise capteur située sur le circuit imprimé (PCB) du SkyAssistant qui mesure la température à l'extérieur du fuselage ou d'autres éléments tels que le pack d'alimentation, le moteur, etc... La plage de mesure de ce thermomètre s'étend de -20°C à +100°C.

    La résolution de mesure est de 0,1 oC. La précision de mesure du capteur (d'après les données fournisseur) est de +/- 1°C dans toute la plage de mesure.
    Les deux capteurs de mesure peuvent être calibrés. La valeur de calibration est sauvegardée dans la variable EA_OFST_TEMP.

    La possibilité de mesurer des températuree est motivée par les raisons suivantes :
  • le capteur extérieur de température rend possible la création de profils de température de l'atmosphère,
  • il permet aussi d'éviter la surchauffe des éléments de puissance comme les moteurs, les batteries ou l'électronique. La hausse de température au-dessus d'un seuil choisi par l'utilisateur peut être signalé par une alarme. La valeur retenue pour le déclenchement de l'alarme est sauvegardée dans la variable EA_ALARM_TEMP.
  • le capteur interne de température permet la compensation thermique de la mesure d'altitude et de la fréquence de l'émetteur.


Description du thermomètre

Description du thermomètre avec capteur LM335

Le circuit associé au thermomètre est le suivant :

Description of thermometer

Le capteur LM335 est utilisé comme capteur externe. Il génère une tension proportionnelle à la température en degrés Kelvin (K). Une augmentation de 1° de la température génère une augmentation de 10mV de la tension de sortie du capteur.

Le signal issu du capteur LM335 (3,73V pour 100oC) est divisé par 1,5 pour être compatible de l'intervalle de mesure du convertisseur analogique / numérique (soit 2,5V). Le capteur est alimenté en 5V par l'intermédiaire d'une résistance 2kOhm pour limiter le risque potentiel de court-circuit sur le capteur.

La température est calculée à partir de la tension issue du capteur avec un taux de 10mV/oC, puis réduit de 273,15 (conversion K -> °C).


Variable EA_OFST_TEMP

Cette variable est utilisée pour ajuster la référence de température des capteurs du SkyAssistant.

La variable est codée sur 4 octets.
Aucune valeur par défaut n'est définie.

octet 3 | octet 2 | octet 1 | octet 0
EXT_TEMP_H | EXT_TEMP_L | INT_TEMP_H | INT_TEMP_L

EXT_TEMP_H..L - compensation (offset) de la température extérieure
INT_TEMP_H..L - compensation (offset) de la température interne


Variable EA_ALARM_TEMP

Cette variable contient la valeur maximale de température au-dessus de laquelle une alarme de trop haute température sera générée.

La variable est codée sur 2 octets.
La valeur par défaut est 0x00001B58

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | AHTEMP_H | AHTEMP_L

AHTEMP_H:AHTEMP_L - valeur de la température au format interne, c'est à dire avant la conversion en °C ou °F.


Voltmètre

La fonction Voltmètre est utilisée pour mesurer la tension d'alimentation de la batterie alimentant le récepteur du modèle R/C. Elle surveille cette tension et alerte sur le risque d'avoir une batterie vide.
La tension est mesurée avec une résolution de 0,01V, ce qui permet d'observer les chutes de tension causées par les servos.

La version logicielle actuelle permet de définir une tension en-dessous de laquelle une alarme sera déclenchée. La valeur de cette tension est sauvegardée dans la variable EA_ALARM_VOLT.


Description du module de mesure de la tension

Dans la version matérielle actuelle, le module se présente comme ci-dessous, afin de prendre en compte la chute de tension due à la présence d'un fusible et du circuit :

voltimeter v1.6

La tension est mesurée uniquement en entrée du récepteur. Grâce à ce principe, il n'y a pas d'erreurs de mesure générées par des circuits externes. Une alarme de tension minimale pourrait se déclencher lorsque SkyAssistant est alimenté via USB ; afin d'éviter cela, une temporisation de 4 minutes avant la génération de l'alarme est utilisée si une transmission USB est détectée. Le SkyAssistant, connecté à un port USB et non utilisé pendant 4 minutes génèrera le message d'alarme de tension trop basse toutes les 20 secondes.

De plus, depuis la version v1.6, un diviseur de tension est utilisé afin de pouvoir mesurer des tensions jusqu'à 12V.
La version v1.5 permet la mesure de tensions jusqu'à 9,5V.


Variable EA_ALARM_VOLT

Cette variable sauvegarde la tension la plus faible en dessous de laquelle une alarme sera déclenchée.

La variable est codée sur 2 octets.
La valeur par défaut est égale à 420.

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | ALVOLT_H | ALVOLT_L

ALVOLT_H..L : tension (V) * 100. Par exemple, une valeur de 352 signifie une tension minimale de 3,52V.


Enregistreur

L'enregistreur est le bloc fonctionnel responsable de l'enregistrement en temps réel des mesures. Ces dernières sont écrites dans une mémoire Flash non volatile. La version actuelle du SkyAssistant comporte une mémoire de 32Mb. Cette mémoire est partagée entre l'enregistreur et le générateur de message vocal.

La mémoire est continuellement remplie dans tout l'intervalle disponible. Si la mémoire est pleine, les données les plus anciennes sont écrasées.

Les données sont écrites sur des pages de 512 octets. Durant l'écriture des données, le SkyAssistant place les données dans la mémoire tampon, puis le contenu de cette mémoire est écrite dans la mémoire Flash. C'est pourquoi à la fin d'un vol, il est nécessaire de patienter quelques instants, afin que les données soient écrites dans la mémoire Flash.

Le résultat des mesures est écrit en format binaire. La description de la structure du fichier binaire est disponible dans un chapitre dédié.

Les données enregistrées sont accessibles via le programme de configuration (Lire un enregistrement... dans le fenêtre de configuration de l'enregistreur). Le fichier lu doit être converti au format texte en utilisant le bouton Conversion d'un enregistrement. Durant la conversion, le programme compense les erreurs des mesures enregistrées.

Le fonctionnement de l'enregistreur est paramétré au moyen de la variable EA_LOGGER_CONF qui définit la période de temps d'enregistrement et le type de données à enregistrer.


Structure du fichier binaire d'enregistrement

Le fichier binaire issu de l'enregistreur est une image de la page en mémoire Flash. C'est pourquoi sa taille est un multiple de 528 octets. Chaque élément de 528 octets contient 16 octets d'entête et 512 octets de données (résultats des mesures). Les données sont sauvegardées sous forme de nombre 16 bits avec un codage de caractère U2.

La structure d'une page du fichier binaire est la suivante :

D00L | D00H | D01L | D01H | D02L | D02H | ... | ...
... | ... | ... | ... | ... | ... | ... | ...
... | ... | ... | ... | D254L | D254H | D255L | D255H
0xAA | 0x55 | CFG | ID_TV | ADRH | ADRL | SSEK | SEK
MIN | GODZ | SESNO | METRIC | FREE | STATUS | SUM L | SUM H

La signification des octets est la suivante :

0xAA55 | Entête de page. Il est vrai que cette entête est placée en fin de page, mais elle décrit de manière non équivoque l'emplacement de la page en mémoire. Dans la pratique, cette chaine étant unique, elle peut être utilisée pour faciliter la recherche de la page suivante
CFG | L'octet log_conf de configuration de l'enregistreur contient des informations sur les canaux en cours d'enregistrement
ID_TV | La moitié d'octet la plus significative est la valeur de la période de temps entre les écritures dans le fichier d'enregistrement. La moitié d'octet la moins significative est l'identificateur du type de données permettant comme D00 d'informer sur la première variable de la page
ADRH..L | Octets le plus et le moins significatif de l'adresse de page
SSEK | Temps (en 1/128ème de seconde) depuis la mise sous tension du SkyAssistant
SEK | Temps (en secondes) depuis la mise sous tension du SkyAssistant
MIN | Temps (en minutes) depuis la mise sous tension du SkyAssistant
GODZ | Temps (en heures) depuis la mise sous tension du SkyAssistant
SESNO | Numéro de sessions (c'est à dire le nombre de cycles de travail depuis la mise sous tension du SkyAssistant
METRIC | Type du système d'unités : FF = métrique ; 00 = impérial
FREE | Non utilisé
STATUS | La moitié d'octet la plus significative contient les motifs d'écriture dans la mémoire : 1 - replissage des données, 2 - interruption par message vocal, 3 - interruption par changement de configuration. La moitié d'octet la moins significative contient le statut de la page mémoire : F = effacée, E = écrite, C = lue
SUM L..H | Checksum modulo 16 des 512 octets de données et des 11 octets d'entête
DxxL..H | Octet le plus et le moins significatif du paramètre enregistré


Variable EA_LOGGER_CONF

Cette variable est codée sur 4 octets.
La valeur par défaut est 0x05008F00.

octet 3 | octet 2 | octet 1 | octet 0
menu_size | menu_min | log_conf | log_time

menu_size - nombre d'article dans le menu de configuration off-line (5)
menu_min - position minimale du menu de configuration off-line (0)

Positions des bits dans la variable log_conf :

bit 7 | bit 6 | bit 5 | bit 4 | bit 3 | bit 2 | bit 1 | bit 0
PPM | PSENSV | RESVD | PRESS | VOLT | ALTI | TEMP | CLIMB

Signification des bits de la variable log_conf :

PPM | Enregistrement du signal PPM
PSENSV | Enregistrement de la tension du capteur de pression
RESVD | Réservé pour les tests et les développements ultérieurs
PRESS | Enregistrement de la pression
VOLT | Enregistrement de la tension
ALTI | Enregistrement de l'altitude
TEMP | Enregistrement de la température
CLIMB | Enregistrement du taux de montée

Signification des valeurs de la variable log_time qui définit la période de temps entre chaque écriture dans le fichier d'enregistrement :

0 | aucun enregistrement (valeur par défaut)
1 | enregistrement toutes les 50ms
2 | enregistrement toutes les 100ms
3 | enregistrement toutes les 200ms
4 | enregistrement toutes les 500ms
5 | enregistrement toutes les 1000ms


Variable EA_SESION_NO

Variable EA_SESSION_NO

Cette variable contient le numéro de la session courante. Une session est une période de travail entre la mise sous tension du SkyAssistant et son arrêt ou son reset. Il est incrémenté à chaque mise sous tension du SkyAssistant.

La variable est codée sur 2 octets.

octet 3 | octet 2 | octet 1 | octet 0
not used | not used | session_H | session_L

session_H..L - numéro de session (sur 16 bits).

Les sessions enregistrées sont visibles dans la fenêtre d'affichage des documents, dans le panneau session :

Sessions in the log


Générateur de message vocal

Le générateur est le bloc fonctionnel responsable de la génération des messages vocaux concernant les paramètres mesurées. Le logiciel actuel gère les paramètres suivants :

  • altitude relative avec alarme d'altitude haute,
  • température extérieure avec alarme de température haute,
  • tension du circuit électrique avec alarme de tension basse,
  • état de l'enregistreur à l'initialisation.

    • Il est également utilisé pour la génération des messages vocaux lors de la configuration off line.

    Le système de génération vocale diffuse des messages enregistrés au préalable. Les messages respectent les règles grammaticales d'un langage donné et contiennent la prononciation de chaque chiffre de 0 à 19, de chaque dizaine de 20 à 90, de chaque centaine de 100 à 900, toutes les unites de mesure et tous les noms des paramètres.
    Les messages sont stockés sous forme de fichier .WAV monophonique avec une résolution de 8 bits et échantillonnés avec une fréquence de 8kHz.

    L'ensemble des messages est enregistré dans une mémoire non volatile après avoir été compilé dans un seul fichier au format .SAW. La compilation normalise l'entête des fichiers .WAV et génère la table d'allocation en ajoutant la longueur et l'adresse de chaque fichier .WAV. Les détails sont fournis dans un chapitre spécifique.

    Est également implémenté dans le logiciel un algorithme de prononciation des messages dans les langues suivantes : anglais, allemand, grec, français, suomi, hollandais, tchèque, italien, hongrois, roumain et polonais. Le nombre de langues disponibles continue d'augmenter !
    L'algorithme reçoit en entrée un nombre binaire et le type de communication qu'il convertit en une liste de messages à diffuser. Les messages sont alors recherchés dans la table d'allocation. Les messages une fois trouvés sont transmis de façon séquentielle au convertisseur numérique / analogique où ils sont convertis en un signal acoustique qui alimente l'émetteur radio.

    La manière de gérer les messages a été réalisée de manière à permettre à l'utilisateur de personnaliser l'ensemble des messsages.


Description du générateur vocal

Le module peut être décrit de la manière suivante :

functional scheme speech generator

Le paramètre d'entrée du générateur de message vocal est une valeur binaire de l'un des paramètres : altitude, température ou tension. Cette valeur est alors convertie au format BCD (valeur sous forme unité, dizaines, centaines). Les valeurs envoyées vers le générateur sont multipliées par 10 pour l'altitude et par 100 pour la température et la tension.

Pour transformer ces valeurs en nombre décimal, une procédure "grammaticale" place la virgule entre les chiffres appropriés.

La procédure "grammaticale" sélectionne un message qui doit être émis vocalement et crée une liste d'index. En fonction de la position de la virgule, le nombre peut avoir différentes formes. Par exemple, le mot "mètre" a différentes formes, comme (un) mètre, (deux) mètres.

Remarque spécifique à la traduction française : ce point ne concerne pas les mots français qui se prononcent de la même manière qu'ils soient au singulier ou au pluriel. L'exemple est plus "parlant" en anglais : (one) meter, (two) meters etc...

Différentes langues ou groupe de langues ont des règles grammaticales différentes pour :

  • les variations de nombres,
  • les variations d'unités,
  • l'ordre des chiffres dans la phrase.

    • Ainsi, une règle particulière a été créée pour chaque langue (en plus des messages).

    L'index créé par la procédure correspond à une position de message dans la table d'allocation. La liste des messages, classés par index, est disponible dans le fichier sample.txt.

    En utilisant le numéro de message, le programme lit les 4 octets suivants dans la table d'allocation placée au début de la mémoire Flash.

    Cette table d'allocation contient l'information sur l'adresse et la longueur du message. Grâce à cette donnée, le programme peut lire les octets liés au message et les place dans la mémoire tampon des messages.

    Cette mémoire tampon est une mémoire RAM de quelques octets utilisée comme mémoire cache pour éliminer les coupures dans la lecture des messages au cours du temps, lorsqu'une nouvelle page mémoire est vidée et qu'une nouvelle est remplie, etc...

    Lorsque les données sont disponibles, la mémoire tampon est entièrement remplie.

    Les données sont alors envoyées depuis la mémoire tampon vers le CAN où elles sont converties en un signal électrique. La transmission des données est cadencée par une horloge interne, fixant le temps entre chaque mot du message, temps égal à 1 / 8kHz = 125us.


Format de fichier SAW

Le fichier SAW contient les messages compilés avec la prononciation associée. La structure de la mémoire est la suivante :

Adresse de la page | Description
0x000 | table d'allocation
0x001 | message 1
0x002 | message 2
... | ...
n | message n
n+1 | message n+1
n+2 | message n+2
... | ...
... | ...
0x47F | dernière page de stockage des messages

La première page (512 octets) est réservée pour la table d'allocation. Le reste des pages est utilisée pour le stockage des messages. Chaque message commence sur une nouvelle page dont l'adresse est décrite sur 16 bits.

La structure de la table d'allocation est la suivante :

Adresse | Description
0x000 | ADR0H | ADR0L | DLG0H | DLG0L | ADR1H | ADR1L | DLG1H | DLG1L
0x008 | ADR2H | ADR2L | DLG2H | DLG2L | ADR3H | ADR3L | DLG3H | DLG3L
... | ...
0x0F8 | ADR126H | ADR126L | DLG126H | DLG126L | ADR127H | ADR127L | DLG127H | DLG127L

Légende :

Adresse - adresse de la table d'allocation dans la mémoire
ADRxxxL - bit de poids faible de l'adresse de début de message
ADRxxxH - bit de poids fort de l'adresse de début de message
DLGxxxL - bit de poids faible de l'adresse de la longueur de message
DLGxxxH - bit de poids fort de l'adresse de la longueur de message

Ce format permet la sauvegarde de 128 messages. La taille d'un message ne peut être supérieure à 2^16 / 8e3 = 8,192s.

Dans la version actuelle, la mémoire attribuée au message s'étend de l'adresse 0x000 à l'adresse 0x47F.


Format du fichier Sample.txt

Ce fichier contient la liste des messages vocaux, dans le même ordre que les messages en mémoire. Vous ne devez pas changer l'ordre des fichiers de message ; seul le nom d'un fichier peut changer. Si le nom est changé, le nouveau nom doit pointer sur un fichier de message existant.

Le fichier est utilisé par le programme wario.exe lors de la compilation des fichiers de message en formet .SAW. Il utilise ce fichier pour déterminer la position d'un message dans la table d'allocation, table dans laquelle la taille et l'adresse du message sont également indiquées.

L'ordre des messages est le suivant :

Index | Value | Sample name
0 | 0 | 0.wav
1 | 1 | 1.wav
2 | 2 | 2.wav
3 | 3 | 3.wav
4 | 4 | 4.wav
5 | 5 | 5.wav
6 | 6 | 6.wav
7 | 7 | 7.wav
8 | 8 | 8.wav
9 | 9 | 9.wav
10 | 10 | 10.wav
11 | 11 | 11.wav
12 | 12 | 12.wav
13 | 13 | 13.wav
14 | 14 | 14.wav
15 | 15 | 15.wav
16 | 16 | 16.wav
17 | 17 | 17.wav
18 | 18 | 18.wav
19 | 19 | 19.wav
20 | 20 | 20.wav
21 | 30 | 30.wav
22 | 40 | 40.wav
23 | 50 | 50.wav
24 | 60 | 60.wav
25 | 70 | 70.wav
26 | 80 | 80.wav
27 | 90 | 90.wav
28 | 100 | 100.wav
37 | 1000 | thousand.wav
41 | "et" | and.wav
40 | "point" | point.wav
46 | - | minus.wav
47 | "tension" | voltage.wav
49 | 1V | volt.wav
50 | >1V | volts.wav
52 | "température" | temperature.wav
54 | 1°C | degree_celsius.wav
55 | >1°C | degrees_celsius.wav
52 | "température" | temperature.wav
54 | 1°F | degree_fahrenheit.wav
55 | >1°F | degrees_fahrenheit.wav
57 | "altitude" | altitude.wav
59 | 1m | meter.wav
60 | >1m | meters.wav
57 | "altitude" | altitude.wav
59 | 1ft | foot.wav
60 | >1ft | feet.wav
62 | Ding...dong | dingdong.wav
63 | "état du variomètre " | status.wav
64 | "enregistreur" | logger.wav
65 | "actif" | active.wav
66 | "inactif" | inactive.wav
67 | "voies enregistrées " | channels.wav
68 | "montée" | climb.wav
69 | "pression" | pressure.wav
70 | "réservé" | reserved.wav
71 | "tension du capteur de pression" | pres_volt.wav
72 | "PPM" | ppm.wav
73 | "temps d'enregistrement " | period.wav
74 | "milli" | mili.wav
75 | "seconde" | second.wav
87 | "attention !" | warning.wav
77 | "Configuration du variomètre" | configuration.wav
78 | "paramètre" | parameter.wav
79 | "égal" | equals.wav
80 | "fin de l'initialisation" | eof_initialization.wav
81 | "taux de montée " | climb_rate.wav
82 | "taux de montée moyen" | climb_averaging.wav
83 | "limite supérieure de la zone de silence" | up_insens_zone.wav
84 | "limite inférieure de la zone de silence" | down_insens_zone.wav
85 | "temps d'enregistrement " | log_per.wav
86 | "menu exit" | menu_exit.wav


Variable EA_SPEECH_CONF

La variable est codée sur 3 octets.
La valeur par défaut est 0x000A803C

octet 3 | octet 2 | octet 1 | octet 0
N/C | time_altitude | speech_conf | speech_time

speech_time - laps de temps entre deux messages.

altitude_time - laps de temps entre deux annonces d'altitude.

Codage des bits de l'octet speech_conf :

bit 7 | bit 6 | bit 5 | bit 4 | bit 3 | bit 2 | bit 1 | bit 0
TIME | CHANNEL | CHANGE | RESVD | VOLT | ALT | TEM | RESVD

Signification des bits de l'octet speech_conf :

TIME | L'émission d'un message est déclenché par intervalle de temps régulier, intervalle défini par l'utilisateur (valeur par défaut)
CHANNEL | L'émission d'un message est déclenché par le canal PPM
CHANGE | L'émission d'un message est déclenché par variation du signal selon une valeur choisie
RESVD | Réservé
VOLT | Message annonçant la tension
ALT | Message annonçant l'altitude (valeur par défaut)
TEM | Message annonçant la température
RESVD | Réservé


Variable EA_VAL_CHANGE

Cette variable sauvegarde la valeur de 3 paramètres. Après multiplication des mesures (voir ci-dessous), un message vocal indiquant leur valeur est émis.

La variable est codée sur 3 octets.
La valeur par défaut est 0x00320132

octet 3 | octet 2 | octet 1 | octet 0
N/C | température | tension | altitude

température - par défaut : 5oC. Si la variation de la mesure courante de température, multipliée par 10, est égale à cette température, un message vocal est déclenché.
tension - fixée à 0,1V. Si la variation de la mesure courante de tension, multipliée par 10, est égale à cette tension, un message vocal est déclenché.
altitude - par défaut : 50m. Si la variation de la mesure courante d'altitude est égale à cette altitude, un message vocal est déclenché.


Variable EA_PPM_RANGE

Cette variable contient 3 paramètres définissant la valeur du signal PPM en fonction de la position du curseur ou du manche. Un message vocal peut être émis par basculement de la valeur du signal PPM de la position neutre 0% à aux positions maximales +100% ou -100%.

Chaque paramètre peut contenir les valeurs suivantes :

0 - position neutre, pas de message
0x05 - déclenchement de l'émission d'un message par la valeur +100%
0x0A - déclenchement de l'émission d'un message par la valeur -100%

La variable est codée sur 3 octets.
La valeur par défaut est 0x00000A05

Byte 3 | Byte 2 | Byte 1 | Byte 0
N/C | TEMP | VOLT | ALTI

TEMP - valeur PPM déclenchant l'annonce de la température
VOLT - valeur PPM déclenchant l'annonce de la tension
ALTI - valeur PPM déclenchant l'annonce de l'altitude


Synthétiseur de son

La fonction principale du synthétiseur de son est de généré un son reflétant l'état de la vitesse verticale, c'est à dire une montée ou une descente.
Une montée est signalée par un son intermittent (plus la montée est rapide, plus le son généré est aigu). De plus, simultanément à l'augmentation de fréquence, la pause entre deux sons est plus courte, ce qui est plus aisé à détecter qu'un changement de fréquence.
Une descente est signalée par un son continu dont la fréquence dépend de la vitesse de descente (plus la descente est rapide, plus le son généré est grave).

Le son est généré par un logiciel utilisant un échantillonnage de signaux de type sinusoïdal. Il est lu par cycles dans la mémoire et est envoyé vers le convertisseur numérique / analogique, puis vers l'émetteur. La vitesse de lecture des échantillons est proportionnelle à la valeur du taux de montée, ce qui provoque une variation par pas du son.

La méthode permettant d'obtenir un son intermittent est paramétrable. Il est possible d'ajuster la pause entre deux sons, de même que la vitesse de variation de longueur de la pause, en fonction du taux de montée. La pause est décrite par une équation de droite : T=V*A+B, tracée en vert sur le graphe, avec T le temps de pause et V le taux de montée. A et B sont des facteurs paramètrables. Le facteur A fait varier la pente de la phase d'attaque du son (lorsque le son commence à être émis) ; le facteur B fait varier la longueur d'émission du son. Les facteurs A et B sont sauvegardés dans la variable EA_SOUND_BREAK.

wykres dzwiêku

La faculté de l'oreille humaine à reconnaître des sons de fréquences proches est réduite. C'est pourquoi il est difficile de distinguer un son interrompu signalant une descente d'un signal intermittent signalant une montée et oscillant autour du zéro. Les deux sont "intermittents" et dans ce cas, une descente pourrait être interprétée comme une montée ! Afin d'éviter cette confusion, la variable EA_VSIG_DISC est utilisée : elle définit une discontinuité du son lorsque le taux de montée est proche de zéro. Grâce à cela, une différence entre un signal de montée et de descente est clairement identifiable. L'inconvénient de cette solution est de réduire l'échelle de son disponible. La valeur de la variable est modifiable par l'utilisateur grâce à la configuration du variomètre

Un planeur volant dans une atmosphère neutre (en l'absence de thermiques) descend sous l'influence de la gravité terrestre. Le taux de descente dépend alors de la finesse du planeur et ne doit pas être confondu avec le taux de descente provoqué par l'atmosphère (par exemple quand le planeur vole dans une zone d'air froid descendante) ou par le pilote mettant son planeur en descente. De manière à bien mettre en évidence le taux de descente propre au planeur, une notion de "zone de silence" a été introduite. Cette zone constitue un intervalle de valeurs de taux de montée pour lesquelles le variomètre n'indiquera ni montée ni descente. Pour une meilleure flexibilité dans le paramétrage, deux variables sont utilisées (pour les limites basse et haute de la zone de silence) : EA_UP_IS_ZONE and EA_DN_IS_ZONE. Leur valeur est renseignée dans la fenêtre de configuration du variomètre.


Variable EA_VOLUME

Cette variable contient les réglages de volume du signal sonore du variomètre et des messages vocaux. Les deux réglages sont indépendants.

La variable est codée sur 3 octets.
La valeur par défaut est 0x0000CCFF

octet 3 | octet 2 | octet 1 | octet 0
sil_coef | N/C | vario | messages

messages - volume des messages vocaux
vario - volume du signal sonore du variomètre
sil_coef - coefficient de réduction du volume en cas d'utilisation dans une bande de fréquence avec modulation réduite de 12,5kHz (PMR)


Variable EA_VSIG_DISC

Cette variable contient le nombre de sons constituant la différence de signal entre le taux de montée minimal et le taux de chute minimal. Chaque son est séparé du suivant de 40Hz.

La variable est codée sur 1 octet.
La valeur par défaut est de 1.

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | N/C | VSIG_DISC


EA_SOUND_BREAK

Variable EA_SOUND_BREAK

Cette variable contient les coefficients A et B de l'équation décrivant le son intermittent du variomètre, ainsi que le temps d'attente entre deux messages vocaux.

La variable est codée sur 3 octets.
La valeur par défaut est 0x00145AFE

octet 3 | octet 2 | octet 1 | octet 0
N/C | delay | Coef B | Coef A

delay - temps d'attente entre deux messages vocaux


Analyseur du signal PPM

L'analyseur est un bloc fonctionnel responsable de la mesure et de l'analyse du signal PPM (longueur des impulsions et écart entre deux impulsions). La longueur des impulsions est normalisée et mesurée en pourcentages, l'écart entre deux impulsions est mesuré en millisecondes.

Le signal PPM est analysé pour :

  • mesurer la valeur du signal,
  • détecter les impulsions surnuméraires,
  • détecter les impulsions de longueur incorrecte,
  • signaler les défauts de liaison radio.

    En se basant sur les mesures, il est communément admis que des impulsions PPM correctes ont une longueur de 0.74-2.25ms et que la distance maximale entre deux impulsions est de 10-25ms.
    A chaque fois que les ces valeurs sont dépassées, un compteur d'erreurs est incrémenté. Si la valeur de ce compteur dépasse le nombre défini dans la variable EA_MAX_PPM_ERR, une alarme est émise. Toutes les secondes, le compteur d'erreur est remis à zéro, ce qui signifie que le décompte des erreurs peut être initialisé au maximum chaque seconde.

    En plus de mesurer les paramètres du signal, le SkyAssistant peut aussi décoder la position d'un interrupteur 3 positions ayant des positions prédéfinies : +100%, 0% and -100%. La limite considérée entre les états est de +50% et -50%. La décodage de la position de l'interrupteur permet de déclencher des messages vocaux et de définir le fonctionnement du variomètre au cours du vol.

    Les possibilités de configuration de l'analyseur sont décrites dans le chapitre Evènements PPM.


Description du bloc fonctionnel d'analyse du signal PPM

Le schéma de l'analyseur PPM est le suivant :

PPM analyser scheme

Le SkyAssistant mesure la durée des impulsions et le temps entre deux impulsions consécutives. Cela est effectué par mémorisation du temps entre les deux fronts de l'impulsion. La longueur de l'impulsion est la période de temps enregistrée entre ces deux fronts.

Comme le contrôleur ne réagit que sur un front descendant, le signal parvient au contrôleur sous sa forme originale et sous sa forme inversée (voir schéma ci-dessus). Un front génère une interruption sur INT0 et le second front sur INT1.

Dans la version logicielle actuelle, le SkyAssistant mesure le signal avec le niveau logique bas de l'impulsion.


Variable EA_PPM_MAX_ERR

Cette variable contient le nombre maximal acceptable d'erreurs PPM en une seconde avant qu'une alarme ne soit émise. En clair, elle permet donc de définir la sensibilité de l'alarme.
La valeur de cette variable de doit pas être supérieure à 50, car cela signifierait que 100% des trames PPM reçues contiennent des erreurs !

La variable est codée sur 1 octet.
La valeur par défaut est de 5

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | N/C | max_err

max_err - nombre maximal accpetable d'erreurs PPM avant qu'une alarme ne soit émise.


Variable EA_ALARM_PPM

Cette variable contient 3 valeurs des paramètres de son de l'alarme PPM.

La variable est codée sur 3 octets.
La valeur par défaut est 0x00101407

octet 3 | octet 2 | octet 1 | octet 0
N/C | time | timbre | number

number - nombre d'éléments composant le son (un élément = un beep ou un silence). Comme le son commence et finit par un silence, le son défini par défaut contient 3 beeps et 4 silences, soit 7 éléments au total.
timbre - timbre du son. C'est un nombre compris entre 0 et 40.
time - durée d'un élément (beep ou silence). C'est un multiple de 4ms.


Variable EA_PPM_LEVEL

Cette variable contient le codage des actions à mener pour des valeurs de signal PPM de +100% et -100%.

La variable est codée sur 2 octest.
La valeur par défaut est 0x00000000.

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | -100VAL | +100VAL

-100VAL - codage action pour une valeur PPM de -100%
+100VAL - codage action pour une valeur PPM de +100%

Codage des actions :

0x01 | 0x02
TONE_OFF | VOICE_OFF

TONE_OFF - le son du variomètre est coupé
VOICE_OFF - les messages vocaus sont coupés


Interface de communication

L'interface de communication est utilisée pour l'échange de données entre le SkyAssistant et le logiciel et pour configurer le SkyAssistant. Elle est également utilisée pour la mise à jour logicielle du SkyAssistant.

La connection du SkyAssistant à l'ordinateur sa fait au moyen d'un convertisseur interne USB / RS232. Il est pour cela nécessaire d'installer les drivers disponibles sur le site du SkyAssistant.
L'interface permet de communiquer dans les deux sens ; par exemple, vous pouvez charger dans le SkyAssistant de nouveaux échantillons de voix ou télécharger sur le PC les enregistrements des vols, etc...
Afin de minimiser le temps nécessaire à l'envoi de gors volumes de données, le transfert se fait en format binaire.
Le protocole de commun est décrit dans le chapitre Format des trames de données.
L'envoi de données est signalé par la LED verte située sur le SkyAssistant.
La connection physique se fait au moyen d'une prise Mini USB standard à 5 contacts (type Canon).

En cas de problème de transmission, un diagnostic peut être établi par un test de transmission.
L'origine classique des problèmes est l'émission de messages vocaux. Cette fonction est en effet hautement prioritaire et requiert presque toute la puissance de calcul CPU ; les autres fonctions sont bloquées lors de l'émission de ces messages.


Format des trames de données

La communication entre le SkyAssistant et le logiciel se fait selon un protocole bien défini. Des trames de données sont échangées entre l'ordinateur (défini comme l'hôte) et le SkyAssistant. L'hôte est toujours celui qui initie la communication.

Une trame de données contient les champs suivants :

Numéro d'octet | Nom du champ | Fonction
1 | Entête | Identification du début de la trame
2H (2 bits les plus significatifs - MSB) | Numéro de trame | Identification de la trame en cas de retransmission
2L (6 bits les moins significatifs - LSB) | Nombre de données | Taille des données dans la trame
3 | Commande | Numéro de la commande à exécuter
4 | Données | De 0 à 12 octets de données
5 | Checksum | Checksum des données et de la commande

La longueur d'une trame minimale (ne contenant pas de données, comme la trame "OK" par exemple) est de 4 octets. La longueur maximale d'une trame est de 18 octets.

Le SkyAssistant répond par l'envoi d'une trame pour chaque trame reçue, sauf pour la trame "Reset" qui n'a pas de réponse, le SkyAssistant étant en réinitialisation.
La trame de réponse contient "OK" ou "ERROR" dans le champ Commande.


Signification des bits de statut

Le codage des bits de l'octet de statut est le suivant :

bit 7 | bit 6 | bit 5 | bit 4 | bit 3 | bit 2 | bit 1 | bit 0
POWER_OK | METRIC_IMP | TEST_OBL | TEST_SOUND | LOGGING | ALARM_VOLT | ZEROW_OK | INITIALIZATION

POWER_OK - ce bit renseigne sur l'état du comparateur du niveau de tension. 1 signifie "tension OK", 0 signifie "tension sous la valeur standard". Dans le cas de courtes chutes de tension, le bit est positionné à 0 et cette valeur est maintenue jusqu'à la lecture du prochain status. Il retourne ensuite à la position courante.

METRIC_IMP - ce bit renseigne sur le système d'unités utilisé. 1 = système métrique ; 0 = système impérial.

TEST_OBL - ce bit informe sur les tests calcul (le SkyAssistant ne fait pas de mesures en temps réel, mais reçoit des données externes).

TEST_SOUND - ce bit indique si un test du son est en cours.

LOGGING - ce bit indique que l'enregistreur est en fonctionnement.

ALARM_VOLT - ce bit renseigne sur l'alarme de basse tension.

ZEROW_OK - ce bit indique la fin de la mise à zéro de l'altitude. 0 signifie que la mise à zéro est en progrès, 1 qu'elle est terminée.

INITIALIZATION - ce bit informe sur le processus d'initialisation. 0 signifie que l'initialisation est terminée, 0 qu'elle est en cours. Il est recommandé d'attendre que l'initialisation soit terminée avant de commencer à lire les données (certaines variables pourraient renvoyer des valeurs incorrectes).


Liste des commandes

N° commande | Nom commande | Description | Paramètre | Format donnée de sortie
0 | CMD_OK | envoie la trame vide OK | aucun | aucun
1 | CMD_WRITE_BUF1 | écrit les données dans le buffer | D0: adresse du buffer, D1..12: données à écrire. | aucun
2 | CMD_READ_BUF1 | lit les données dans le buffer | D0: adresse du buffer, D1: nombre de données. | D0..11: données lues
3 | CMD_MEM_BUF1 | transfert des données de la mémoire dans le buffer | D0..1: adresse mémoire (H..L) | aucun
4 | CMD_BUF1_MEMER | transfert des données du buffer vers la mémoire (avec effacement préalable) | D0..1: adresse mémoire (H..L) | aucun
5 | CMD_ERASE_BLOK | effacement de bloc mémoire | D0..1: adresse du bloc (H..L) | aucun
6 | CMD_RD_CHECKSUM | lit le checksum de page mémoire | D0..1: numéro de page (H..L) | D0..1: Checksum
7 | CMD_USE_FLASH_ON | active les fonctions utilisant la flash | aucun | aucun
8 | CMD_USE_FLASH_OFF | arrête les fonctions utilisant la flash | aucun | aucun
9 | CMD_BUF_MEMBE | transfert des données du buffer vers la mémoire (sans effacement préalable) | D0..1: adresse mémoire (H..L) | brak
10 | CMD_RD_EEPROM | lit 4 octets de la page mémoire EEPROM (variable de configuration) | D0: adresse de page (adresse de la variable) | D0..3 valeurs lues (L..H)
11 | CMD_WR_EEPROM | écrit 4 octets de la page mémoire EEPROM (variable de configuration) | D0..3 contenu de la page (L..H) D4: adresse de page | none
12 | CMD_READ_TIME | lit le temps système du SkyAssistant | aucun | D0..2: HH:MM:SS au format binaire
13 | CMD_SET_TIME | fixe le temps système du SkyAssistant | D0..2: HH:MM:SS en format binaire | aucun
14 | CMD_RD_POMARY1 | lit : altitude, température, tension, taux de montée | aucun | D0..1: Altitude (L..H), D2..3: Température (L..H), D4-5: Tension (L..H), D6-7: Taux de montée (L..H)
15 | CMD_RD_POMARY2 | lit : tension du capteur de pression, pression, réserve, PPM, numéro de son, état des micro-interrupteurs DIP | aucun | D0..1: Tension du capteur de pression (L..H), D2..4: Pression (L..M..H), D5-6: réservé (L..H), D7: valeur PPM, D8: numéro de son, D9: état des micro-interrupteurs DIP
16 | CMD_ADC_CALIBR | renvoie les coefficients de calibration du CAN | aucun | D0..2: contenu du registre ADCOFS (L..H) D3..4 contenu du registre ADCGAIN (L..H)
17 | CMD_ | non utilisé | aucun | aucun
18 | CMD_RESET_DEV | réinitialise le SkyAssistant | aucun | aucun
19 | CMD_TEST_TRANSM | teste la transmission: retourne les données envoyées | D0..x: données test (x=1..12) | D0..x: données test
20 | CMD_RD_VERSION | lit la version du micro-contrôleur et du numéro de série | aucun | D0..5: Firmware version D6..9: Serial number
21 | CMD_RD_STATUS | lit l'état du SkyAssistant | aucun | D0: status byte, D1: time to the end of initialization process, D2: error code
22 | CMD_RD_SEC_REG | lit le registre sécurité | aucun | D0..15: security register value(L..H)
23 | CMD_SET_FREQA | fixe le contenu du registre fréquence | D0..2: registre fréquence 0A..2A (LSB en premier) | none
24 | CMD_CALIBRATE | calibre l'émetteur | aucun | none
25 | CMD_TEST_DZWIEK | teste le calcul du numéro de son | D0..1: valeur du taux de montée | D0: numéro de son D1: présence dans la zone de silence
26 | CMD_GET_STATUS_RF | lit les registres état de l'émetteur | aucun | D0: registre CAL D1: registre LOCK D2: registre PLL D3: registre PaPow
27 | CMD_MOW_SAMPLA | joue un mot | D0: numéro de mot | aucun
28 | CMD_MOW_KOMUNIKAT | joue un message | D0: numéro de message | aucun
29 | CMD_GET_FREQA | lit le registre fréquence | aucun | D0..3: registre fréquence FREQA
30 | CMD_MOW_ALARM_PPM | émet l'alarme PPM | aucun | aucun
31 | CMD_GET_SAMP_DATA | lit dans la table d'allocation l'adresse et la taille d'un message | D0: numéro de message | D0..1: adresse du message (L..H) D2..3: longueur du message (L..H)
32 | CMD_SET_TEST_MODE | bascule en mode calcul et test du signal sonore du variomètre | D0: numéro du mode de test (les 2 bits les moins significatifs sont importants) | aucun
33 | CMD_RD_PAGE_STATUS | lit le statut de la page mémoire flash | D0: numéro de page à lire | D0..x: Statut des pages lues
34 | CMD_SET_WYS_VAL | joue les messages d'altitude en mode test | D0..1: valeur de l'altitude (L..H) | aucun
35 | CMD_GET_VREF_GND | vérifie la valeur de GND et VRef | aucun | D0..1: valeur de VRef (L..H) D2..3: valeur de GND (L..H)
36 | CMD_SET_OFFSET_GAIN | écrit les coefficients de calibration | D0..1: valeur du registre offset (L..H) D2..3: valeur du registre gain (L..H) | aucun
37 | CMD_CHIPCON_CURR_WR | écrit le registre courant des puces électroniques | D0: valeur du registre | aucun

Chaque commande génère de la part du SkyAssistant une réponse sous forme d'une trame (sauf CMD_RESET_DEV). Il y a deux possibilités de réponse : Vrai ou Faux. VRAI peut être vide ou contenir des données, FAUX contient un code d'erreur.

N° réponse | Type réponse | Description
Identique au n° de commande | OK | Réponse positive. Peut contenir les données telles que décrites dans la table ci-dessus
0xFF | CMD_ERR | Erreur commande. Le code d'erreur est envoyé en retour (voir ci-dessous)

Codes d'erreur :

N° erreur | Nom erreur | Description
200 | ERR_IL_DANYCH | nombre de données incorrect
201 | ERR_CRC | CRC de trame de données incorrect
202 | ERR_POLECENIE | numéro de commande incorrect
203 | ERR_WERYF | erreur de vérification d'écriture dans l'EEPROM


Emetteur radio

Le SkyAssistant contient un émetteur FM équipé de la synthèse de fréquence pouvant travailler dans la gamme de fréquence 400-500MHz. Les bandes suivantes sont disponibles :

  • PMR (446,00625 - 446,09375 MHz) - 8 canaux,
  • LPD (433,075 - 434,775 MHz) - 69 canaux,
  • FRS1 (462,5625 - 462,7125 MHz) - 7 canaux,
  • FRS2 (467,5625 - 467,7125 MHz) - 7 cannaux.

    CAUTION! Particular bands can be used only in the following countries:

    • Bande | Pays
PMR | Autriche, Belgique, République tchèque, Danemark, Finlande, France, Grèce, Espagne, Pays-Bas, Islande, Irlande, Luxembourg, Allemagne, Pologne, Portugal, Suisse, Suède, Turquie, Grande Bretagne, Italie.
LPD | Autriche, Pays-Bas, France, Allemagne, Norvège, Italie (canaux 1-20)
FRS | USA

    La réception des signaux est possible grâce à n'importe quel récepteur LPD, PMR ou FRS.
    L'émetteur a une puissance de sortie de 10 dBm (10 mW).
    Le canal est choisi au moyen de micro-interrupteurs DIP . La lecture de la position des micro-interrupteurs est réalisée seulement après la mise en route du SkyAssistant. Pour changer le canal d'émission de l'émetteur, il faut positionner les micro-interrupteurs DIP avant de (re)démarrer le SkyAssistant.
    Prze³±cznik DIP
    Les 5 premiers micro-interrupteurs sont utilisés pour coder le numéro de canal.
    Pour lire le numéro de canal, la valeur binaire donnée par la position des micro-interrupteurs DIP (voir tableau ci-dessous) doit être :

  • augmentée de 1 et multipliée par 2 (pour la bande LPD).
  • augmentée de 1 (pour la bande PMR).

    • Micro-interrupteur | 1 | 2 | 3 | 4 | 5 | 6
Valeur binaire | 1 | 2 | 4 | 8 | 16 | 32

    Par exemple, pour la configuration donnée par défaut sur la figure ci-dessus, la valeur binaire est égale à 2, ce qui donne un numéro de canal de (2+1)*2=6. Le SkyAssistant ne permet la sélection que des canaux pairs.

    Le micro-interrupteur n°6 gère le choix de la sélection de la bande (voir la liste complète des canaux).


Liste des canaux disponibles de l'émetteur

Liste des canaux de l'émetteur en fonction de la position des micro-interrupteurs DIP

1) Bandes européennes LPD/PMR

Canal \ DIP | 1 | 2 | 3 | 4 | 5 | 6
LPD 2 | OFF | OFF | OFF | OFF | OFF | OFF
LPD 4 | ON | OFF | OFF | OFF | OFF | OFF
LPD 6 | OFF | ON | OFF | OFF | OFF | OFF
LPD 8 | ON | ON | OFF | OFF | OFF | OFF
LPD 10 | OFF | OFF | ON | OFF | OFF | OFF
LPD 12 | ON | OFF | ON | OFF | OFF | OFF
LPD 14 | OFF | ON | ON | OFF | OFF | OFF
LPD 16 | ON | ON | ON | OFF | OFF | OFF
LPD 18 | OFF | OFF | OFF | ON | OFF | OFF
LPD 20 | ON | OFF | OFF | ON | OFF | OFF
LPD 22 | OFF | ON | OFF | ON | OFF | OFF
LPD 24 | ON | ON | OFF | ON | OFF | OFF
LPD 26 | OFF | OFF | ON | ON | OFF | OFF
LPD 28 | ON | OFF | ON | ON | OFF | OFF
LPD 30 | OFF | ON | ON | ON | OFF | OFF
LPD 32 | ON | ON | ON | ON | OFF | OFF
LPD 34 | OFF | OFF | OFF | OFF | ON | OFF
LPD 36 | ON | OFF | OFF | OFF | ON | OFF
LPD 38 | OFF | ON | OFF | OFF | ON | OFF
LPD 40 | ON | ON | OFF | OFF | ON | OFF
LPD 42 | OFF | OFF | ON | OFF | ON | OFF
LPD 44 | ON | OFF | ON | OFF | ON | OFF
LPD 46 | OFF | ON | ON | OFF | ON | OFF
LPD 48 | ON | ON | ON | OFF | ON | OFF
LPD 50 | OFF | OFF | OFF | ON | ON | OFF
LPD 52 | ON | OFF | OFF | ON | ON | OFF
LPD 54 | OFF | ON | OFF | ON | ON | OFF
LPD 56 | ON | ON | OFF | ON | ON | OFF
LPD 58 | OFF | OFF | ON | ON | ON | OFF
LPD 60 | ON | OFF | ON | ON | ON | OFF
LPD 62 | OFF | ON | ON | ON | ON | OFF
LPD 64 | ON | ON | ON | ON | ON | OFF
PMR 1 | OFF | OFF | OFF | OFF | OFF | ON
PMR 2 | ON | OFF | OFF | OFF | OFF | ON
PMR 3 | OFF | ON | OFF | OFF | OFF | ON
PMR 4 | ON | ON | OFF | OFF | OFF | ON
PMR 5 | OFF | OFF | ON | OFF | OFF | ON
PMR 6 | ON | OFF | ON | OFF | OFF | ON
PMR 7 | OFF | ON | ON | OFF | OFF | ON
PMR 8 | ON | ON | ON | OFF | OFF | ON

2) Bandes américaines : FRS
Canal \ DIP | 1 | 2 | 3 | 4 | 5 | 6
FRS 1 | OFF | OFF | OFF | OFF | OFF | OFF
FRS 2 | ON | OFF | OFF | OFF | OFF | OFF
FRS 3 | OFF | ON | OFF | OFF | OFF | OFF
FRS 4 | ON | ON | OFF | OFF | OFF | OFF
FRS 5 | OFF | OFF | ON | OFF | OFF | OFF
FRS 6 | ON | OFF | ON | OFF | OFF | OFF
FRS 7 | OFF | ON | ON | OFF | OFF | OFF
FRS 8 | ON | ON | ON | OFF | OFF | OFF
FRS 9 | OFF | OFF | OFF | ON | OFF | OFF
FRS 10 | ON | OFF | OFF | ON | OFF | OFF
FRS 11 | OFF | ON | OFF | ON | OFF | OFF
FRS 12 | ON | ON | OFF | ON | OFF | OFF


Variable EA_FREQ_OFST

Cette variable est codée sur un octet.

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | N/C | offset

offset - valeur de l'offset ajouté au registre de fréquence.

L'offste permet l'ajustage fin de l'émetteur et du récepteur.


Variable EA_XOSC

Cette variable contient la valeur de la fréquence fondamentale du circuit oscillant de l'émetteur. Elle est utilisée pour calculer la fréquence du signal radio.

La variable est codée sur 3 octets.
La valeur par défaut est 0xF42400 (16000000)

octet 3 | octet 2 | octet 1 | octet 0
N/C | XOSC | XOSC | XOSC


Micro interrupteurs DIP

DIP Switch
Les micro interrupteurs DIP sont utilisés pour choisir le canal de l'émetteur radio.

L'initialisation de l'émetteur est réalisée uniquement lors de la mise sous tension du SkyAssistant, ce qui implique que les changements effectués ne seront pris en compte qu'à la suite d'un redémarrage.


CAN (Convertisseur Analogique Numérique)

Le SkyAssistant est équipé d'un CAN 12 bits. Il peut être calibré, ce qui signifie que sa plage de travail peut être ajustée de manière optimale par rapport au signal mesuré. Il comporte deux registres :
  • GAIN - ajustement de l'amplification du signal mesuré, qui permet de faire correspondre la limite de la plage de travail du CAN avec le niveau de la tension de référence.
  • OFFSET - ajustement des deux bornes de la plage de travail du CAN par rapport au signal mesuré. Cela permet d'ajuster le zéro du CAN au zéro du signal.
    Les deux registres sont stockés dans la variable de configuration EA_OFFSET_GAIN.


Comment calibrer le CAN ?

Actuellement, la calibration du CAN est réalisée manuellement en utilisant l'interface ci-dessous.
L'objectif est de modifier l'échelle de mesure du CAN afin de la faire coïncider avec l'intervalle de mesure souhaité.

La calibration consiste à déplacer l'échelle de compensation (Offset) et faire varier le gain ((Gain).
Le curseur Offset déplace l'échelle de mesure de manière à faire correspondre son zéro avec le zéro du CAN.
Le curseur Gain est utilisé pour faire correspondre la limite supérieure de l'échelle de mesure avec la valeur 4095 du CAN.

Le CAN peut mesurer une valeur minimum correspondant à la masse (GND) du SkyAssistant et une valeur maximum correspondant à la tension de référence (VRef). Le CAN est correctement calibré lorsque la mesure de GND retourne 0 et que la mesure de VRef retourne 4095.
Si le CAN n'est pas correctement calibré, les résultats fournis par le SkyAssistant seront faux, avec des mesures d'altitude, de tension, de température ou de taux de montée fausses, ou une lecture incorrecte de l'état des micro-interrupteurs DIP (canal radio incorrect).

Calibration window

Sur la figure ci-dessus, le CAN n'est pas correctement calibré. En effet, l'histogramme GND (valeurs les plus fréquemment retournées) est centré sur la valeur 4 avec un léger dépassement vers la valeur 5. De plus, l'histogramme VRef est centré sur la valeur 4087 avec un léger dépassement de +-0,7 bit de chaque côté.

La première action est de déplacer le curseur Offset, puis de rafraichir le graphique en utilisant le bouton Générer l'histogramme. Ce processus sera à répéter jusqu'à ce que le point le plus haut de l'histogramme GND soit positionné sur l'abscisse 0. Comme une partie de l'histogramme sort de l'échelle visible, le réglage optimal est obtenu lorsque la partie visible de l'histogramme GND se situe entre 0 et 1 (le pic de l'histrogramme doit se trouver sur le 0).

A ce stade de la calibration, l'histogramme VRef n'est pas pris en compte.

Le graphe obtenu devrait être semblable à celui présenté ci-dessous :

Calibration window

L'étape suivante consiste à régler le Gain. Déplacer le curseur jusqu'à ce que l'histogramme VRef atteigne l'extrémité droite du graphique. L'histogramme doit être contenu dans le dernier intervalle de l'échelle avec un pourcentage de mesures visibles de 50%.

A cette étape, vous ne devez pas modifier la position du curseur Offset, car cela provoquerait un déplacement des deux histogrammes.

Un CAN correctement calibré génèrera un graphique semblable à celui présenté ci-dessous :

Calibration window

Si l'on déplace trop l'un des deux paramètres, le graphique peut sortir de l'échelle visible.
Par exemple, sur la figure ci-dessous, la valeur du gain est trop forte (l'histogramme VRef est hors graphique (pourcentage de mesures visibles égal à 0%).

Calibration window

Dans ce cas, il faut déplacer le curseur Gain vers la gauche et rafraichir le graphique jusqu'à ce que l'histogramme VRef apparaisse à nouveau (pourcentage de mesures visibles différent de 0%).


Variable EA_OFFSET_GAIN

Cette variable contient les valeurs de deux facteurs de calibration du conertisseur analogique numérique (CAN) et est codée sur 4 octets (pas de valeur par défaut).
Octet 3 | Octet 2 | Octet 1 | Octet 0
GAIN_H | GAIN_L | OFFSET_H | OFFSET_L

OFFSET_H..L - Registre de la partie basse de la plage du convertisseur (zéro)
GAIN_H..L - Registre de la partie haute de la plage du convertisseur (4069)


Procédures

Il existe quelques procédures à respecter pour s'assurer d'un fonctionnement correct du SkyAssistant (par exemple, la calibration correcte des modules de mesure).

La version logicielle permet les procédures suivantes :
Initialisation matérielle
Configuration Off-line
Calibration en température


Initialisation

L'initialisation est réalisée juste après un reset ou une mise sous tension du SkyAssistant.

C'est une période de temps nécessaire pour la stabilisation des conditions de travail du module différentiel. Durant cette période, le SkyAssistant a un mode de fonctionnement différent du mode normal. Les différences sont les suivantes :

  • Il n'y a aucun signal du variomètre, mais seulement un beep toutes les 3 secondes.
  • Un changement de la valeur du signal PPM lance la configuration on line.
  • Le SkyAssistant ne permet pas de lancer un grand nombre de commandes liées au programme de configuration.
  • Tant que la mise à zéro de l'altitude n'est pas achevée, le SkyAssistant ne retourne aucun résultat concernant les autres paramètres (cela nécessite généralement un très court laps de temps).

    • Par défaut, l'initialisation dure 55 secondes. Cette durée est paramétrable par l'utilisateur et est sauvegardée dans la variable EA_INIT_TIME.
    Une période d'initialisation trop courte conduit le variomètre à fonctionner avec un signal indiquant la portance dégradé (très fort taux de chute) comme présenté sur le graphe ci-dessous :

    zbyt krótka inicjalizacja

    Cela ne pose aucun problème en vol, mais conduit à un son généré déplaisant et à un intervalle de mesure du taux de montée inutilement étendu vers le bas.


Variable EA_INIT_TIME

Cette variable est codée sur un octet.

Elle définit la durée de la période d'initialisation en secondes. La valeur par défaut est :

  • 55 (0x37) pour la version matérielle v1.5
  • 30 (0x1E) pour la version matérielle v1.6

    • La valeur peut être fixée de 1 à 254.

    octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | N/C | Init_time


Configuration "off-line"

Configuration "off-line" (sans l'aide d'un ordinateur)

La configuration "off-line" est une procédure permettant de changer les paramétrages du SkyAssistant sur le terrain, sans avoir besoin d'un ordinateur. Il est réalisé par dialogue entre l'utilisateur et le SkyAssistant.
Le SkyAssistant annonce les paramètres à modifier et l'utilisateur les confirme ou les ignore par changement de la valeur du signal PPM (c'est à dire en bougeant les manches de l'émetteur radio).

Cette méthode est très simple et conviviale. L'utilisateur a deux solutions pour effectuer son choix :

  • il fait varier la valeur du signal PPM de 0% à +100% ou de 0% à -100% pour ignorer le paramètre et passer au paramètre suivant,
  • il patiente quelques secondes jusqu'à expiration du délai d'attente pour valider la modification du paramètre.

    Diagramme des états de communication :
    Off-line configuration diagram

    La configuration actuelle contient 3 menus de gestion des paramètres:
  • menu principal, où le nom et le numéro du paramètre sont annoncés,
  • menu paramètre, où le nom du paramètre et sa valeur sont annoncés,
  • menu modification du paramètre, où la valeur du paramètre est incrémentée par pas de 1. Lorsque la valeur maximale est atteinte, la valeur retourne à la valeur initiale.


Calibration de la température

La calibration des capteurs de température est réalisée dans la fenêtre statistique de mesures :

Measurements statistics window

Remarque : afin d'effectuer cette calibration, vous aurez besoin d'un thermomètre de référence supplémentaire.

Avant la calibration, le SkyAssistant devra être mis sous tension et fonctionner depuis quelques minutes pour stabiliser la température des deux capteurs. En effet, un courant circule dans les capteurs et les réchauffent. C'est particulièrement important pour le capteur interne.

Il faut ensuite entrer dans le champ de saisie de la Température la température lue sur le thermomètre de référrence puis lancer une série de mesures en cliquant sur le bouton Démarrage. Une fois cette série terminée, les erreurs de compensation seront calculées et affichées dans le panneau inférieur de la fenêtre. Un appui sur le bouton Réglage offset de température permettra le stockage de ces erreurs dans la variable de configuration EA_OFST_TEMP.

Les erreurs de compensation seront soustraites des mesures suivantes afin que les températures données par les deux thermomètres (interne et externe) soient les plus proches l'une de l'autre.


Mise à jour logicielle

Depuis la version 1.5, la mise à jour logicielle est automatisée et déplacée dans le programme de configuration principale. Une fois la fonction choisie, la fenêtre suivante apparaît :
start aktualizacji

Pour charger une nouvelle version, cliquer sur le bouton "Update" . La fenêtre suivante apparaît (les fichiers de mise à jour du logiciel sont au format AFW):
wybór pliku

Il faut ensuite choisir le fichier à télécharger, puis cliquer sur "Ouvrir". Le programme place alors le SkyAssistant en mode Programmation, identifie le controleur, écrit les données et replace le SkyAssistant en mode Opérationnel. La mise à jour est signalée par une barre de progression lors du téléchargement du logiciel et par des messages explicatifs. Ci-dessous un exemple d'affichage :

Cette fenêtre peut être close en cliquant sur "Quitter" une fois la barre de progression complète. Le SkyAssistant sera alors réinitialisé et pourra être à nouveau utilisé de manière classique.

En cas d'interruption lors de la programmation, le SkyAssistant restera sans programmation valide et ne pourra pas fonctionner. Il suffit alors simplement de télécharger un nouveau programme en procédant de la même manière que pour une mise à jour classique. La seule différence visible réside dans le fait que le SkyAssistant ne peut pas répondre aux commandes envoyées par le logiciel de mise à jour. Toutes les commandes seront donc effectuées après atteinte du timeout, ce qui a pour seul effet un ralentissement très marqué dans l'ouverture des fenêtres de commande et de mise à jour. Hormis ce ralentissement, l'opération de programmation s'effectue avec succès.


Description des connecteurs

Le SkyAssistant présente un nombre réduit de connecteurs. Les schémas ci-dessous préentent leur description.

Pour le PCB version 1.5 :
SkyAssistant v1.5 connectors

Pour les PCB version 1.6 et 1.7:
SkyAssistant v1.6 connectors

Côté gauche, de haut en bas :
Connecteur capteur : il est utilisé pour connecter le capteur de température (type LM335 ou autre avec un signal de sortie compris entre 0 et 3.75V). C'est un connecteur mâle à 2 ou 3 contacts (dépend de la version PCB).

Connecteur d'alimtation et PPM : il est utilisé pour connecter l'alimentation du SkyAssistant (via le récepteur RC) et pour la réception du signal PPM (permettant le contrôle du SkyAssistant et l'analyse du signal RC). C'est un connecteur standard Hitec.

Mini USB (5 contacts, type Canon) : il est utilisé pour connecter le SkyAssistant à un ordinateur afin d'échanger les données et de permettre les mises à jour logicielles. Un câble Mini USB standard peut être utilisé.

Côté droit :
Antenne de l'émetteur radio du SkyAssistant. Elle est composée d'un câble souple d'une longueur de 164mm.


On-line configuration

On-line configuration est une procédure pour changer les paramètres du variomètre sur le terrain et sans avoir accès à un ordinateur. Ceci est possible en utilisant un "dialogue" entre l'utilisateur et le module. Le variomètre propose les options et l'utilisateur accepte ou refuse en changeant la valeur du signal PPM (en changeant la position de l'interrupteur sur la radio).
Grâce à la flexibilité et à la simplicité de cette méthode, l'utilisateur peut faire cela en deux temps:

  • en changeant la valeur du signal PPM de 0% à +100% ou de 0% à -100%. Ceci signifie: aller à l'option suivante.

  • attendre quelques secondes, ceci signifie: valider le paramètre

    Diagramme des états de communication:
    On-line configuration diagram

    Chaque paramètre se configure en trois étapes:

  • menu principale, où le nom du paramètre et son numéro sont prononcés,

  • menu de paramétrage, où le nom et la valeur du paramètre sont prononcés,

  • menu d'incrémentation du paramètre, où le paramètre est incrémenté par 1. Après avoir atteint la valeur maximale, le compteur recommence à zéro.


Modify voice commands

Commandes de modification des messages vocaux

Ces commandes permettent d'écouter et de changer les messages vocaux (au format .wav).

Le fichier correspondant à un message vocal doit être au format approprié : mono, 8kHz, 8 bits.

Si l'utilisateur souhaite utiliser des messages plus longs, il doit les compiler en un nouveau fichier .SAW et charger ce dernier dans le SkyAssistant. C'est un processus très lourd en temps nécessaire.

Testowanie i modyfikacja sampli

Les informations disponibles dans la fenêtre ci-dessus sont les suivantes :

La liste des messsages contient :

  • le numéro de message,
  • le nom du fichier contenant le message, extrait du fichier sample.txt,
  • l'adresse en mémoire du début du message,
  • la taille en octets du message,
  • le taux de remplissage de la mémoire : taille du message / (nombre de pages mémoire utilisées * taille de la page mémoire).

    ATTENTION ! pour sélectionner un message particulier, il faut cliquer sur le nom de ce message. Les autres champs ne permettent pas la sélection.

    Changer msg. - ouvre une page de dialogue pour charger un nouveau fichier à la place du fichier sélectionné.

    Prononciation - joue le message sélectionné.

    Changer le chemin d'accès - permet le changement de chemin d'accès au répertoire contenant le fichier sample.txt. Le chemin d'accès est rappelé dans le champ situé en bas de la fenêtre.


Variable EA_SAMP_BREAK

Cette variable contient la valeur du délai entre deux messages vocaux.

La variable est codée sur 1 octet.
La valeur par défaut est 0x14 (20), soit 80ms.

octet 3 | octet 2 | octet 1 | octet 0
N/C | N/C | N/C | delay

delay - valeur du délai (multiple de 4ms).


Histeresis of vario signal

Hystérésis du signal du variomètre

L'hystérésis définit le temps minimal pendant lequel le signe du taux de montée ne doit pas changer afin d'être identifié comme un signal de montée ou de descente, permettant alors au signal audio d'être généré. Autrement dit, un filtre passe-bas filtre les petites perturbations du signal autour du zéro du taux de montée.

Histeresis of vario signal
Exemple de la signalisation acoustique en fonction du signal du variomètre : a) AVEC hystérésis, b) SANS hystérésis

Sur la figure ci-dessus, l'effet de l'hystérésis est visible : tous les signaux de durée plus courte que la valeur choisie par l'utilisateur sont filtrés. Grâce à cela, le signal audio est plus "lissé" et les signaux non significatifs (d'un point de vue de recherche d'ascendances) ne sont pas pris en compte.
Un effet similaire est obtenu en ajustant la zone de silence, mais la zone de silence filtre les signaux de faible amplitude, alors que l'hystérésis filtre les signaux de faible durée.